HIS 7870 causes PC to not boot

Hi, I recently bought a HIS 7870 2GB to upgrade from my 6850 from newegg. I received it and installed it in my pc. Upon booting, there were no beeps, no display on screen. It was weird. I switched back to my 6850 and it all worked well. I thought it was the video card that was defective, so I RMA'd it. I just got the new one tonight...same problem. I just don't get it...it doesn't make any sense at all. I have a 850W PSU, never gave me problems. I have an AMD FX-8120 CPU and a ASRock 970 Extreme4 mobo. I don't see where the problem lies... Can anyone help me?

Thanks a lot
3 answers Last reply
More about 7870 boot
  1. I should add that all the fans of the pc are spinning including the Video card. So i'm clueless here :(
  2. strange in full stress power consumption should be around 274W ,im nvidia user what are the pin connection 2x6 or 6 and 8 i mean do you have cables directly from psu no tweaks..
  3. hey, i fixed the problem. Thanks! It was 2x6pin connectors.
    I updated my BIOS and changed the PCIE VDDA voltage in bios to 1.93V (max one)...it appears both of these things did the trick. Or one of them. Anyways, it works now :)
Ask a new question

Read More

Radeon Boot Graphics