Sign in with
Sign up | Sign in
Your question
Closed

Farcry 3 FPS Issues

Last response: in Graphics & Displays
Share
February 22, 2013 4:29:21 AM

Hello, I recently bought a amd 6950 and overclocked to 6970 and have been having issues with Farcry 3. The problem is that my FPS stays around 12 even at the main menu. I doubt it would be my computer hardware since I am able to run Battlefield 3 maxed out at 60 FPS.
If there is any reason for this i would like to know it. My specs are:
I5-2500k @4.2GHz
2TB hardrive
120GB SSD
XFX 6950 unlocked to 6970
16GB G.skill ram

More about : farcry fps issues

a b U Graphics card
February 22, 2013 5:07:13 AM

Don't even compare such "optimized-for-low-level-hardware" games as Butthurtfilled 3 and Far Cry 3.
Butthurtfilled 3 can run at 55~60 FPS on low settings even with GTX 550 Ti (THE most weakest Nvidia card at the current time). IN MULTIPLAYER.
Besides, Far Cry 3's waaay too fresh of a game, much fresher than Butthurtfilled 3.
You have a very solid build but your GPU's too old for such games as Far Cry 3 nonetheless. Really, the only thing you should upgrade in your build, is GPU.

Just get a newer card of "HD 7870~7950" level (or, of course, higher), and you'll see major boost in performance.
Score
0
February 22, 2013 5:12:11 AM

Ugh i thought it would perform better then my gtx 560 non ti which got 60 fps on very high on farcry 3
Score
0
Related resources
a b U Graphics card
February 22, 2013 5:17:32 AM

LOLWUT?

Hmmm...

Remind me...does Far Cry 3 utilize PhysX? Maybe that's the case.
You probably turned PhysX ON, and since Radeons don't support PhysX by default, you might've got severe FPS drop solely because of that.
You can HPX Radeons just fine (a cheap GT 640 would be more than enough...or you can use your GTX 560, if you still have it), but by default Radeons don't have PhysX at all, thus switching CPU-calculated PhysX will turn into massive FPS drop at the end. That might be your case exactly...if Far Cry 3 has PhysX settings, try turning them off and see if you get FPS boost. If not, then it's either that PhysX is hard-coded in the game (some games has that), or you really need to upgrade your GPU to a "787x+"-level card.
Score
0
a c 186 U Graphics card
February 22, 2013 5:29:29 AM

SNORT said:
Ugh i thought it would perform better then my gtx 560 non ti which got 60 fps on very high on farcry 3
:heink:  noway maybe on a low res monitor but for 1080p you need a better card if you plan to max that game out
Score
0
February 22, 2013 5:35:24 AM

The main thing that is making it seem like this isnt hardware is that i wasnt trying to max out my game and is always locking around 12 fps even on lowest. It doesnt change if i hire the settings its just always the same.
Score
0
a b U Graphics card
February 22, 2013 5:35:56 AM

To OP - What is your resolution?
If you had better FPS with the 560 this is probably a driver problem since you moved from Nvidia to AMD, try to uninstall all drivers, run a driver cleaner program and reinstall the latest 6950 drivers. Also try to run the 6950 first with default clocks.
Score
0
a b U Graphics card
February 22, 2013 5:36:21 AM

SNORT said:
Always locking around 12 fps even on lowest.


Ugh...how about installing some drivers/updating them?
Or are you using Virtu in i-mode, by any chance? O_o Naaah, that can't be the case...

Bigcyco: Make up your mind already, man! %)
Score
0
a c 186 U Graphics card
February 22, 2013 5:38:29 AM

FunSurfer said:
To OP - What is your resolution?
If you had better FPS with the 560 this is probably a driver problem since you moved from Nvidia to AMD, try to uninstall all drivers, run a driver cleaner program and reinstall the latest 6950 drivers. Also try to run the 6950 first with default clocks.
+1 i agree
Score
0
February 22, 2013 6:03:33 AM

I've already tried reinstalling drivers and deleting all my old ones.
Same thing keeps happening even on lower resolutions.
And there is no physx option.
Score
0
a c 186 U Graphics card
February 22, 2013 6:19:38 AM

There nothing i know of that you can do except buy a better card then sorry maybe someone else will know wait for more replies good luck.
Score
0
February 22, 2013 6:21:39 AM

Well thanks for the help anyway.
Score
0
a b U Graphics card
February 22, 2013 6:46:28 AM

Yeah, man...looks like the only option left for you is to do as I suggested in the first post. Get yourself a better/fresher Radeon card of at least "7870" level.
Far Cry 3 isn't that kind of a game to be "optimized enough" to be friendly with GPUs of older generations, on old tech-process.
Score
0
a c 186 U Graphics card
February 22, 2013 6:48:36 AM

SNORT said:
Well thanks for the help anyway.
no problem your welcome sorry i couldn't help good luck.
Score
0

Best solution

a b U Graphics card
February 22, 2013 6:49:22 AM
Share
a b U Graphics card
February 22, 2013 6:51:29 AM

Oh damn...I totally forgot about that, lol. Ж)))))))))
Yeah, OP, you should definitely try that.
Score
0
February 23, 2013 1:51:34 AM

Best answer selected by SNORT.
Score
0
a b U Graphics card
February 23, 2013 5:45:41 AM

So...I guess it worked, huh...
Score
0
a c 169 U Graphics card
February 23, 2013 8:59:31 AM

This topic has been closed by Maziar
Score
0
!