Sign in with
Sign up | Sign in
Your question

Radeon 5850 new install w/black screen

Last response: in Graphics & Displays
Share
February 22, 2013 10:15:44 PM

Hey all,

I have a M61PMV mobo that's maxed out.

4gb Ram

quad core cpu

650 watt psu.

I bought a Radeon 5850 card to replace my 5750.

I've spent the last several hours trying to get the 5850 to work.

All appears well with the card, IE: fan runs, and no rare beeps from the pc on bootup.

I have Installed and reinstalled it 4 times already.

I've reset the cmos on my mobo. The Bios is p10.

I have triple checked the seating of, and power to the card.

After uninstalling the 5750 drivers, I shut down the PC, remove the 5750, and install the 5850.
When I start the pc... I get a black screeen only. PC still beeps in at the normal times.

I'm at a loss here and would appreciate any advice on troubleshooting this.
February 24, 2013 4:13:54 PM

I have the same problem. I spent probably 3 or 4 hours trying to fix it yesterday.

I got it working with a Corsair 520Watt Power supply if I unplugged the second hard drive and the optical drive.

I ordered a Corsair 650 Watt power supply and it didn't work. I only got the black screen, tried going back to the 520Watt in the old configuration and it didn't work.

So now I need to test it on another computer and see what the deal is. If I can't get it to work I guess I'll RMA the card.

What 5850 do you have? Mine is the Generic Radeon 5850.
m
0
l
February 24, 2013 6:28:56 PM

I have a solid black model (prob generic).

I brought the card up to our local pro's office and had them bench it. The card works fine.
The guy told me that if the card isn't backwards capable(2.0 to 1.0) then my mobo won't read it.
I've read where they say it is backwards capable but I fear that even if I get this running on this mobo it will bottle-neck badly.
I'm leaving my 5750 in this rig and building another rig tomorrow. I'll keep this thread open (lol..hopefully "they" will) so I'lll let ya know.

Thanks for your info though :) 
m
0
l
February 24, 2013 8:08:07 PM

Well the model I have of the 5850 seems to be somewhat finicky with power, I'll test it on another rig tomorrow though.
m
0
l
!