Sign in with
Sign up | Sign in
Your question

MSI R7950 Twin Frozr fan problem

Last response: in Graphics & Displays
Share
February 23, 2013 11:04:31 AM

Hi there

My GPU fan is acting weird. When playing games or stress testing the fan's RPM skyrockets AND is annoyingly inconsistent (+/- 200 RPM) although the card is only hovering around 55 degrees Celsius.

I've tried locking it via CCC and Afterburner at 45% (and it stays like that) but it seems like I have no control over the RPM.

I had a faulty 660 ti before I installed this one, so I'm wondering if that might have an effect (although it shouldn't).

If I don't find a solution soon I'm going to have to try and re-install the OS.

So I am here searching for solutions. Has anyone encountered this problem before?

More about : msi r7950 twin frozr fan problem

February 24, 2013 11:46:39 AM

gledigondull said:
Hi there

My GPU fan is acting weird. When playing games or stress testing the fan's RPM skyrockets AND is annoyingly inconsistent (+/- 200 RPM) although the card is only hovering around 55 degrees Celsius.

I've tried locking it via CCC and Afterburner at 45% (and it stays like that) but it seems like I have no control over the RPM.

I had a faulty 660 ti before I installed this one, so I'm wondering if that might have an effect (although it shouldn't).

If I don't find a solution soon I'm going to have to try and re-install the OS.

So I am here searching for solutions. Has anyone encountered this problem before?


I got one of these cards yesterday and i'm having the same issue. As soon as the temps hit 58 - 60c, the fan will ramp up to 100% whether or not i've set the fan control to manual. I've tried the latest bios on the card, and also put it under stress in Linux to rule out any driver issues. Still has the same problem.

Does yours stay locked at 45% even when the temps hit 60+?

I think i'm just gonna RMA mine.
February 25, 2013 2:15:05 AM

Mine does not stay locked at 45%.

As soon as it hits 55-57 degrees the fans go wild. And not even consistent. Hovering around full speed.

Also tested this thing more yesterday and noticed it jumps between 100% and 64% GPU load when it gets above 55 degrees.

I'm RMA-ing mine tomorrow as well. Good luck. :) 
Related resources
March 4, 2013 3:26:51 PM

I have exactly the same problem with the same card. RMA'd the first card, but the replacement does the same thing. Any of you get any joy from replacing?
March 4, 2013 3:34:47 PM

I got mine replaced and had exactly the same problem. Gonna get a Gigabyte instead. Looks like all MSI 7950's made recently have this issue. I guess they cheaped out on the fan controller or something.
!