Sign in with
Sign up | Sign in
Your question

PowerColor HD 6870 issues

Tags:
  • PowerColor
  • Blue Screen
  • HD
  • Graphics
Last response: in Graphics & Displays
Share
February 24, 2013 8:40:38 AM

Hi,

I recently bought a PowerColor HD 6870 for my PC. Since then, iam getting a blue screen(Vertical stripes alternating with grey stripes) after booting win 7(64-bit). I have tried with various AMD catalyst softwares(13.1 , 12.10, 12.8, etc) and getting the same result every time. Kindly let me know the possible reason for this BSOD.

My PC config.

MOBO - Intel DG35EC
CPU - Core2Quad Q8400 6M
RAM - Transcend - 8 Gb (2 Gb - 4 sticks)
PSU - Seasonic S12II - 520W

Regards,
Jan

More about : powercolor 6870 issues

February 24, 2013 10:10:32 AM

Sounds like artifacts. If they didn't go away after the driver update, you may have a defective card there. Try and RMA it, if it's still under warranty.
m
0
l
February 24, 2013 12:02:24 PM

Quote:
Sounds like artifacts. If they didn't go away after the driver update, you may have a defective card there. Try and RMA it, if it's still under warranty.


Its been only a week since i had bought it so its still covered under warranty. I had previously owned a Nvidia Geforce 210. Had uninstalled all of the previous drivers using windows uninstaller as well as using driver sweeper. So the possibility of software/driver intrusion can be ruled out right?
m
0
l
February 24, 2013 12:05:07 PM

Yup. And it's not like your card will have accumulated so much dust for a week that it would start to overheat and show artifacts...
m
0
l
!