Sign in with
Sign up | Sign in
Your question

Problem with gigabyte radeon 7870

Tags:
  • Radeon
  • Drivers
  • Gigabyte
  • Graphics
Last response: in Graphics & Displays
Share
February 27, 2013 3:46:43 PM

Hello i have a problem with my new graphic card Gigabyte radeon 7870. well i started downloading all the windows and ATI drivers and i downloaded farcry 3 after all the drivers were installed. i was gaming on the computer all day but suddently my screen started blinking black and dead pixels appeared on my screen. a bubble appeared AMD drivers has stopped restponding an has succesfully restored . i reinsalled windows 7 and it worked fine but when i installed the drivers again it started blinking and dead pixels appeared again. i have to use (DVI-i single link) because hdmi wont work anymore. i tried to reinstal my computer and install the drivers one last time it worked fine without drivers . i installed the drivers. the computer boots up but immediately before i can enter my desktop the screen turns black and i cant do anything. but i can boot it fine in safe mode. and the stats says the GPU gives 1.0/7.9 score/rating.
so im wondering if its the graphic card or the mobo thats broken.

sorry for bad english i hope you understand what im trying to say. :) 

please help

Specs:
INTEL CORE I5 3570K 3.4GHZ 6MB S-1155 IVY
GIGABYTE RADEON HD7870 OC WINDFORCE 2GB PCI-E DVI/HDMI/DP
CORSAIR TX 750W M MODULAR PSU NEW
ASUS P8Z77-V PRO Z77 S-1155 ATX IVY

More about : problem gigabyte radeon 7870

February 27, 2013 3:50:00 PM

If I were you, I would uninstall the drivers, and then use Driver Sweeper or equivalent program to make sure there are no remaining AMD drivers, then reinstall.
February 27, 2013 4:19:59 PM

yeah i tried that when i booted after the drivers were installed the screen goes black before i boot into the desktop :/  what do you think the problem is is it the gpu or the mobo ?
!