Closed

Gpu black screens

So I just built my first PC today, i3 3220, gtx 660 super clocked, 500w PSU, 8gigs corsair vengeance, gigabyte z77m d3h MVP mobo. So I got it built installed windows and got right to messin around. I got the latest GPU drivers and all windows updates. I installed guildwars2 for a quick test. I used the nvidoa control panel to get to a 1920x1080p resolution etc. I started the gas,e and put it too max settings. Game ran from 70fps-120fps. After like 4 mins I black sscreened them it came back but playing at a solid 20-27fps. I lowered settings but didn't see much of a change. Restarted the game and did the same thing. Then I ran 3dmark 11 and didn't make it very far, the screen started lagging them it crashed giving me a windows kernel nvidia error fail. Idk what is wrong can someone help?
11 answers Last reply
More about black screens
  1. check if you nvidia driver are up to date.
  2. Downloaded latest drive from website 5 mins ago still no change. Even called evga and they are clueless
  3. could you test that gtx 660 in another system she could be defective .
  4. I will take it to my friends house and give her a try. see
  5. Ialso think this may be the PSU, my computer whistles and it seems,s when the GPU starts running for a couple of mins it see,s to enter a limp mode in that game.
  6. spentar said:
    Ialso think this may be the PSU, my computer whistles and it seems,s when the GPU starts running for a couple of mins it see,s to enter a limp mode in that game.


    Whistling can be a few things, noisy fan, leaking capacitor from either the PSU or the graphics card (gfx card more likely)

    Just a quick note on that power supply although you don't mention the brand name, I'm currently using a 500w Antec (good brand) with a system roughly the same power as yours (i5 3570k stock, 7950 Asus CUII stock, 8gb Corsair Dominator, Asus P8H77-V and a few hard drives) as my current one is being RMA'd and I also get a slight whistling whilst starting FIFA 13 and all my games have had slight flickering, symptoms of not enough power to the GPU. Just throwing that in there in case you have a non branded PSU for future reference.

    I would do exaclty as scout_03 has said, check the GPU if its fine in someone elses computer, if thats ok and it passes 3d mark then run something like this on your friends computer http://mikelab.kiev.ua/index_en.php?page=PROGRAMS/vmt_en

    To check the all of the VRAM is all ok and working.
  7. @snuus i will try this software on my graphic card .
  8. soo i called EVGA today and we went over some things and my psu is garbage. the 3.3v reading in the bios displays its at 4.175 and its suppose to be at 3.3-3.4:/ so im returning the psu and getting a corsair tx750w. i dont need that much but im planning on upgrading anyways. that might not be the cause of the issue but that is an issue also. im brining the card to a buddies house tomorrow for more tests.
  9. i juat reinstalled the gpu and delted all drivers and re installed and downloadded gpu Z. the sensor claims its running a core clock of like 400 when just browsing the internet
  10. /bump
Ask a new question

Read More

Graphics Cards GPUs Graphics