Sign in with
Sign up | Sign in
Your question
Closed

GPU problem, please help

Last response: in Graphics & Displays
Share
February 28, 2013 3:08:24 AM

Guys, I’m having an issue with my new 7970. I’ve been using it to play Far Cry 3, and it works very well for that. I disabled SSOA per someone’s suggestion, and I’ve been able to run everything maxed out with 3 screens with a very respectable framerate. I was thrilled at first, but then things started happening. I started to notice weird artifacts. Forgive my layman description, but this is the best I can do.

I assume that when textures load, there is a different set of textures for things that are a great distance, medium distance, and close distance. As I get closer to an object, be it a rock or a house, at some point it changes from a far texture to a medium texture, and then to a close texture. When the changeover occurs, I notice a weird checkerboard effect for the objects while it changes over. It is a very weird occurrence, and becomes highly noticeable. It seems that as time has progressed, the changeover becomes slower and more noticeable, but that could just be my perception of it changing as I notice it more, I don’t know.

Then the game started freezing. It would happen after about 2-4 hours of playing, and the image would be stuck on the screen, with a very small, very weird artifact somewhere on the screen. I had to use task manager at that point to close the game. Then yesterday, my screen went haywire, and a very strange full-screen discoloration occurred, with very bright colors all over the screen. When I alt-tabbed out of the game, the weird discoloration continued in Windows. I had to restart the computer to get it to go away. It looked similar to this:



I am really, really hoping that it’s a software issue, because I don’t want to ship this card back, but I doubt that. Do you guys think it could be an issue with Far Cry 3? It doesn’t happen when I play rFactor, or when I use the Assetto Corsa tech demo. I ran 3dmark 11 one time, and nothing happened then. I’ll run some more of those back to back and post back, but mill it over guys, and let me know what you think. I downloaded HWMonitor and the CPU temps look outstanding. GPU temp was 72 after a long (error free) session of Far Cry 3. Didn’t check temps after 3dmark, but I will, and post back.

Do you guys know of another benchmark I could use to really stress test the GPU, or should I just send the sucker back? I bought it about 20 days ago from Newegg. Any other tips?

No overclocking whatsoever on any component, cleaned and dusted the case really well before I put the new card in, adequate airflow, really good fans, all fans working, relatively new PSU.

Thanks guys.

XFX Double D FX-797A-TDBC Radeon HD 7970 Black Edition 3GB
http://www.newegg.com/Product/Product.aspx?Item=N82E168...
ASUS M4A89TD PRO/USB3
AMD Phenom II X6 1100T Black Edition Thuban 3.3GHz
3x CORSAIR XMS3 4GB 240-Pin DDR3
Western Digital WD Black 1TB 7200 RPM SATA
Don't remember details on PSU, but I think it's a 650W

More about : gpu problem

Best solution

a b U Graphics card
February 28, 2013 3:25:01 AM

Your temps look fine. First try a driver update (to beta maybe). Also run some benchmarks on the card to see if it does this under load. You might have to rma the card :/ 

---

sorry just read that you already ran the benchmarks.

Also you might want to upgrade your cpu sometime soon because its bottle necking you system
Share
February 28, 2013 4:43:38 AM

I've tried the 13.1 driver and the 13.2 beta driver, happens with both. I just ran a 1 hour session of Assetto Corsa tech demo with no problems, GPU got up to 74.

What is the best benchmark to try?

Thanks.
Score
0
Related resources
February 28, 2013 5:10:41 AM

UPDATE: Just found FurMark and ran it for about 10 minutes, no problems, GPU temp 76. Gotta go to bed, will run longer tomorrow.
Score
0
March 3, 2013 2:42:05 AM

Been having artifacts in other games now. RMA outbound.
Score
0
March 3, 2013 2:42:16 AM

Best answer selected by ccjcc81.
Score
0
!