Sign in with
Sign up | Sign in
Your question
Closed

Radeon HD 7950 - Display driver stopped working (Only certain games)

Tags:
  • Radeon
  • Graphics
Last response: in Graphics & Displays
Share
February 28, 2013 9:38:42 PM

***UPDATE***

It appears the GPU only crashes when I have my CCC Scaling Options set to 0% so that the screen fills my entire TV. When the scaling is set to the default, I have no crashes at all. Does anybody have any idea on how to get rid of the black box/get the screen to fill my TV without messing with the scaling options since it seems my $300 GPU can't handle it.

Hello, recently I've been having crashes when trying to start games where when I start, it will freeze and I will get the "AMD Display driver stopped responding but has recovered" notice and the game will freeze. I've tried uninstalling the drivers, rebooting into safe mode and using driver sweeper to fully delete along with CC Cleaner, then re-installing fresh drivers (I've done this 3 times). However, it seems to work for a bit but the problem always comes back.

Specs:

ASRock Z77 Extreme4
Intel i5-3750K
Gigabyte Radeon HD 7950
8GB 1600 RAM
128GB Samsung SSD
2TB Toshiba internal HD
SeaSonic 650W power supply

** I don't have anything overclocked by the way **

All my temperatures are normal, none above 50. I've re-seated the GPU, no change.

The weird thing is, when I start The Witcher 2, I have no problems running it. Same with Hotline Miami. When I start BF3 as soon as I click join server and get the pop-up message before the game launches I get the error, same when I open the Guild Wars 2 launcher it will freeze automatically and give me the error message. After wiping my drivers the 2nd time I was able to start BF3, I could play DayZ fine, blah blah but it always seems to start happening again eventually and it's driving me insane. I've ran the MemTest to check if it was my RAM for some reason, and no problems there either.

Should I try updating my BIOS?

More about : radeon 7950 display driver stopped working games

February 28, 2013 9:47:37 PM

Seagate? Pretty sure they dont make PSUs, do you mean SeaSonic? Make sure you check.
Score
0
February 28, 2013 9:55:22 PM

vrumor said:
Seagate? Pretty sure they dont make PSUs, do you mean SeaSonic? Make sure you check.


Haha sorry you're right, SeaSonic.
Score
0
Related resources

Best solution

March 1, 2013 2:33:14 AM

idol said:
Hello, recently I've been having crashes when trying to start games where when I start, it will freeze and I will get the "AMD Display driver stopped responding but has recovered" notice and the game will freeze. I've tried uninstalling the drivers, rebooting into safe mode and using driver sweeper to fully delete along with CC Cleaner, then re-installing fresh drivers (I've done this 3 times). However, it seems to work for a bit but the problem always comes back.

Specs:

ASRock Z77 Extreme4
Intel i5-3750K
Gigabyte Radeon HD 7950
8GB 1600 RAM
128GB Samsung SSD
2TB Toshiba internal HD
SeaSonic 650W power supply

** I don't have anything overclocked by the way **

All my temperatures are normal, none above 50. I've re-seated the GPU, no change.

The weird thing is, when I start The Witcher 2, I have no problems running it. Same with Hotline Miami. When I start BF3 as soon as I click join server and get the pop-up message before the game launches I get the error, same when I open the Guild Wars 2 launcher it will freeze automatically and give me the error message. After wiping my drivers the 2nd time I was able to start BF3, I could play DayZ fine, blah blah but it always seems to start happening again eventually and it's driving me insane. I've ran the MemTest to check if it was my RAM for some reason, and no problems there either.

Should I try updating my BIOS?


You should NEVER load anything into your computer like CC cleaner or driver sweeper.
Windows needs NOTHING to run correctly. The more "free" software you load, the more problems you will have.
These type of "free" downloads are a scam, and will improve NOTHING.
Sign in as administrator (If you are not administrator you may be blocked)
Close all the applications that are being used...save and close your files...
Turn Off the antivirus and firewall, turn off the functions of windows defender.
If you have multiple security programs installed, they must be turned ALL off. Security will prevent your driver from installing...
Download the latest CCC driver package, and save it to an easy location. Make sure this is the correct driver for your card.
Delete all the current AMD video software and drivers, restart the system (the video will look screwy, don't worry)
Now load install all the newest CCC drivers and restart the system (the driver will not work (yet) as you said, but load it anyway)
left click start
left click computer
right click C drive
Left click Open
Right click Users
Left click properties
"Check" mark the box that says: Attributes: "Hidden" (there is now a check-mark in the "Hidden" box)
Click: "Apply"
Now the system will apply the hidden attributes...and this will take a while, or maybe a long while. Let this proceed, and don't interrupt it...
During this procedure, a message may inform you that you do not have administrator privilege to the file you are trying to change the attributes of. That's OK. Just click: "ignore all."
When this procedure is finished, click OK (the box will close after you click OK)
Now you will once again be looking at folders in C drive (don’t close the C drive window or you may regret it)
(once again) right click Users
(once again) left click properties
UN- check the box that says: Attributes "Hidden" (you will now take the check mark OUT, Hidden is no longer checked)
Click Apply
Now the computer will UN-apply the hidden attributes, and it may take a while, or a long while...but let it proceed, and finish, don't interrupt it.
During this procedure, a message may inform you that you are not the administrator of the file that you are trying to change the attributes of. That's OK, just click: "ignore all."
When this is completed click OK
Now close all windows and restart the computer
turn all the security back on.
At this point, the CCC should be functional. Open the CCC and test the functions...

Click Start, Click Control Panel, Click ( in power options) Choose a Power Plan
Check the Box that says "high performance"
Click "change plan settings"
Turn off display: set to NEVER
Put the computer to sleep: set to NEVER
Click: Change advanced plan settings
Select "high performance" from the drop down menu
Scroll down the list: Click on the + signs to expand the choices for each item on the list.
Require a password on wake up: set to NO
Hard disk: turn off the hard disk: set to NEVER
Wireless adapter settings:
Sleep: set to NEVER
Allow Hybrid sleep: set to NEVER
Hibernate after: set to NEVER
Allow wake timers: set to disable
USB settings:
USB selective suspend setting: set to NEVER
Power Buttons and lid:
Power button action: Setting: set to shut down
Sleep Button Action: set to: do nothing
PCI Express:
Link State Power Management, Setting: OFF
Processor Power Management:
System Cooling Policy: setting: Active
Display
Turn off display after: setting: NEVER
Multimedia Settings:
When Sharing Media: Setting: Prevent idling to sleep
When Playing Video: Setting: Optimize Video
Click APPLY
Click OK

Go into the power profiles,
set standby, hibernate and sleep to OFF
leave the monitor standby ON, that's OK (maybe not, try OFF)
Set the Hard Drive standby to NEVER
Set system Performance to MAXIMUM, not "quiet mode."

Open the bios set up and make sure "cool and quiet" is OFF. (AMD)
If there is a power saver or a "quiet mode" in the bios, shut it off...
There may be a performance setting in the bios setup you have...make sure it's cranked up to max.
in the bios, see that the allocation for video, if available, is maxed.

Now open the hardware manager profiles...
click start
click computer
click system properties
click device manager
double click on mice and other pointing devices
right click on HID compliant mouse
left click on properties
click on the power management tab
UN-check the box that says: "allow the computer to turn off this device to save power." (there is now NO check mark in this box)
click OK

Now repeat this procedure for all mice, monitors, keyboards, and ALL USB ports on the device manager list.

You must open ALL the devices one at a time, as above, and turn off the power saver, for each device.

Share
March 1, 2013 11:30:38 AM

soundguruman said:
You should NEVER load anything into your computer like CC cleaner or driver sweeper.
Windows needs NOTHING to run correctly. The more "free" software you load, the more problems you will have.
These type of "free" downloads are a scam, and will improve NOTHING.
Sign in as administrator (If you are not administrator you may be blocked)
Close all the applications that are being used...save and close your files...
Turn Off the antivirus and firewall, turn off the functions of windows defender.
If you have multiple security programs installed, they must be turned ALL off. Security will prevent your driver from installing...
Download the latest CCC driver package, and save it to an easy location. Make sure this is the correct driver for your card.
Delete all the current AMD video software and drivers, restart the system (the video will look screwy, don't worry)
Now load install all the newest CCC drivers and restart the system (the driver will not work (yet) as you said, but load it anyway)
left click start
left click computer
right click C drive
Left click Open
Right click Users
Left click properties
"Check" mark the box that says: Attributes: "Hidden" (there is now a check-mark in the "Hidden" box)
Click: "Apply"
Now the system will apply the hidden attributes...and this will take a while, or maybe a long while. Let this proceed, and don't interrupt it...
During this procedure, a message may inform you that you do not have administrator privilege to the file you are trying to change the attributes of. That's OK. Just click: "ignore all."
When this procedure is finished, click OK (the box will close after you click OK)
Now you will once again be looking at folders in C drive (don’t close the C drive window or you may regret it)
(once again) right click Users
(once again) left click properties
UN- check the box that says: Attributes "Hidden" (you will now take the check mark OUT, Hidden is no longer checked)
Click Apply
Now the computer will UN-apply the hidden attributes, and it may take a while, or a long while...but let it proceed, and finish, don't interrupt it.
During this procedure, a message may inform you that you are not the administrator of the file that you are trying to change the attributes of. That's OK, just click: "ignore all."
When this is completed click OK
Now close all windows and restart the computer
turn all the security back on.
At this point, the CCC should be functional. Open the CCC and test the functions...

Click Start, Click Control Panel, Click ( in power options) Choose a Power Plan
Check the Box that says "high performance"
Click "change plan settings"
Turn off display: set to NEVER
Put the computer to sleep: set to NEVER
Click: Change advanced plan settings
Select "high performance" from the drop down menu
Scroll down the list: Click on the + signs to expand the choices for each item on the list.
Require a password on wake up: set to NO
Hard disk: turn off the hard disk: set to NEVER
Wireless adapter settings:
Sleep: set to NEVER
Allow Hybrid sleep: set to NEVER
Hibernate after: set to NEVER
Allow wake timers: set to disable
USB settings:
USB selective suspend setting: set to NEVER
Power Buttons and lid:
Power button action: Setting: set to shut down
Sleep Button Action: set to: do nothing
PCI Express:
Link State Power Management, Setting: OFF
Processor Power Management:
System Cooling Policy: setting: Active
Display
Turn off display after: setting: NEVER
Multimedia Settings:
When Sharing Media: Setting: Prevent idling to sleep
When Playing Video: Setting: Optimize Video
Click APPLY
Click OK

Go into the power profiles,
set standby, hibernate and sleep to OFF
leave the monitor standby ON, that's OK (maybe not, try OFF)
Set the Hard Drive standby to NEVER
Set system Performance to MAXIMUM, not "quiet mode."

Open the bios set up and make sure "cool and quiet" is OFF. (AMD)
If there is a power saver or a "quiet mode" in the bios, shut it off...
There may be a performance setting in the bios setup you have...make sure it's cranked up to max.
in the bios, see that the allocation for video, if available, is maxed.

Now open the hardware manager profiles...
click start
click computer
click system properties
click device manager
double click on mice and other pointing devices
right click on HID compliant mouse
left click on properties
click on the power management tab
UN-check the box that says: "allow the computer to turn off this device to save power." (there is now NO check mark in this box)
click OK

Now repeat this procedure for all mice, monitors, keyboards, and ALL USB ports on the device manager list.

You must open ALL the devices one at a time, as above, and turn off the power saver, for each device.


Thank you, I will try this when I get home. Also, do you think the Intel HD graphics drivers that are installed could be messing with the AMD drivers?
Score
0
March 1, 2013 8:35:38 PM

Ok soundguruman,

I followed your instructions step-by-step and am still getting the error. Also, I uninstalled the Intel HD Graphics Driver as well just to see if it was interfering with the CCC drivers, but I guess that didn't make a difference. Another thing, when I uninstalled the AMD drivers and restarted, my video never looked any different.

Am I following the right procedure when uninstalling?:

- Control Panel
- AMD CCC
- Change
- Express Uninstall
- Restart

That's how I've been uninstalling the drivers.
Score
0
March 1, 2013 9:13:18 PM

***UPDATE***

It appears the GPU only crashes when I have my CCC Scaling Options set to 0% so that the screen fills my entire TV. When the scaling is set to the default, I have no crashes at all. Does anybody have any idea on how to get rid of the black box/get the screen to fill my TV without messing with the scaling options since it seems my $300 GPU can't handle it.
Score
0
March 2, 2013 1:46:24 AM

Well, we do know that the larger the display, the more CPU is loaded.
Perhaps you are actually maxing out the CPU, and that's why it goofs up.
Reducing the size (not full screen) runs OK, and the CPU is loaded less.
Increasing the size loads the CPU more...and then it goofs up.
push control alt delete. Open the task manager.
Look at the CPU and RAM load, is it getting close to 100%???
When you get near 100% this indicates the the processor is overloaded.
Score
0
March 2, 2013 2:02:36 AM

When I set the scaling to Overscan (0%) the memory is at 1.25GB and CPU at 0% with no games running.

If I try to start BF3, memory jumps up a bit and my CPU jumps up to 58% before the game freezes trying to load. I suppose the CPU could be maxing out then?
Score
0
March 2, 2013 2:52:38 AM

soundguruman said:
Well, we do know that the larger the display, the more CPU is loaded.
Perhaps you are actually maxing out the CPU, and that's why it goofs up.
Reducing the size (not full screen) runs OK, and the CPU is loaded less.
Increasing the size loads the CPU more...and then it goofs up.
push control alt delete. Open the task manager.
Look at the CPU and RAM load, is it getting close to 100%???
When you get near 100% this indicates the the processor is overloaded.

A Pentium 4 could handle 1080p full screen at 20% usage at idle im sure the 3570k it would be near impossible to crash it from cpu usage even something like say 5 4k resolution monitors... As for the OP right click your desktop and click personalize and change it to fit screen or whatever your preference is. Also there is nothing wrong with CCleaner it is a perfectly legitimate program i have been using for years. I have also never bought a Virus software... I use Malwarebytes and Avast and have !NEVER! had a virus on any scan.
Score
0
March 2, 2013 4:51:11 AM

u said u have TV connected to pc if so what is ur tv doest it have some settings like picture format or somthing like that and u just put it to wide screen
i have same problem with older games and in ccc no settings help but i do it with TV setup i put wide screen and is ok but normal usage i set it to unscaled
Score
0
March 2, 2013 12:11:44 PM

helper800 said:
A Pentium 4 could handle 1080p full screen at 20% usage at idle im sure the 3570k it would be near impossible to crash it from cpu usage even something like say 5 4k resolution monitors... As for the OP right click your desktop and click personalize and change it to fit screen or whatever your preference is. Also there is nothing wrong with CCleaner it is a perfectly legitimate program i have been using for years. I have also never bought a Virus software... I use Malwarebytes and Avast and have !NEVER! had a virus on any scan.


Thanks guys, I was definitely wondering about that as I didn't think my CPU should be getting maxed out but I guess it made sense.

I'll check the windows options when I get home, and for bravo14 I tried setting my TV to widescreen but even then there's still black borders at the top and bottom like a widescreen movie. Thanks for the help guys and I'll give an update when I get home.
Score
0
March 2, 2013 4:30:46 PM

Well, by setting my TV mode to widescreen and upping the overscan a bit the screen now fills my entire TV without crashing when I try to start a game. The downside though is now I have to switch my TV between normal and widescreen when I'm on the PC or watching TV.
Score
0
March 2, 2013 5:38:07 PM

Thats because its a TV. TVs arent a good solution as PC displays. And now you see why :)  Good you got it working tho.
Score
0
March 2, 2013 6:35:55 PM

vrumor said:
Thats because its a TV. TVs arent a good solution as PC displays. And now you see why :)  Good you got it working tho.


Haha thanks. I plan on getting some monitors soon.
Score
0
March 2, 2013 6:36:44 PM

Best answer selected by idol.
Score
0
!