Low FPS GTX 680

Hey Folks, I just upgraded mu GPU from a GTX 560 and I'm a little sad because there is no improvement. In fact there is actually a slight degradation.

I am only getting about 28 average FPS in some of the games I play like Tera, Hawken, Planet Side 2 and Mech Warrior online.

I'm running the latest drivers from Nvidia's site. I thought I had a halfway decent build but I'm not sure what is going on. Any help is appreciated.

Here are my specs

Windows: Windows 7 Ultimate Edition (64-bit) Service Pack 1 (Build 7601)
Memory (RAM): 8192 MB
CPU Info: AMD Athlon(tm) II X4 640 Processor
CPU Speed: 3013.3 MHz
Display Adapters: NVIDIA GeForce GTX 680
Monitors: 2x; Generic PnP Monitor
Screen Resolution: 1920 X 1080 - 32 bit
Motherboard *: ASUSTeK Computer INC. M4A88TD-V EVO/USB3
5 answers Last reply
More about tomshardware
  1. Looks like the CPU is a bottleneck. Open Task Manager, go to performance, go into any game you want, play a little, let the CPU and GPU do some work and immediately alt tab out of the game and see the charts in the performance tab. If the CPU was hitting a 100% then the CPU is the bottleneck. Just don't test this method on Planetside 2 because it's such a CPU intensive game anyway and it will max out any CPU you throw at it.
    Report back your results for a free cookie.
  2. XYMan said:
    Looks like the CPU is a bottleneck. Open Task Manager, go to performance, go into any game you want, play a little, let the CPU and GPU do some work and immediately alt tab out of the game and see the charts in the performance tab. If the CPU was hitting a 100% then the CPU is the bottleneck. Just don't test this method on Planetside 2 because it's such a CPU intensive game anyway and it will max out any CPU you throw at it.
    Report back your results for a free cookie.



    Ok so I don't think is the CPU cause I had the performance manager running on my second monitor as I was playing the games and here are the results.

    Hawken
    60 FPS
    65% CPU usage
    60% GPU usage

    Mech Warrior Online
    31 ish FPS
    70% CPU usage
    45% GPU usage

    Tera
    35 FPS
    60% CPU Usage
    35% GPU usage


    Not sure WTF happened with Hawken but it looks beautiful now. So I'm stumped as all get out....


    I can has cookie now?
  3. XYMan said:
    Looks like the CPU is a bottleneck. Open Task Manager, go to performance, go into any game you want, play a little, let the CPU and GPU do some work and immediately alt tab out of the game and see the charts in the performance tab. If the CPU was hitting a 100% then the CPU is the bottleneck. Just don't test this method on Planetside 2 because it's such a CPU intensive game anyway and it will max out any CPU you throw at it.
    Report back your results for a free cookie.


    So it was the CPU....... Over clocked it to 3.5 using the Auto tune function in the BiOS and also disabled Cool'nQuiet. Getting about 50- 60 fps. CPU temp maxed out at 42c in Mech warrior Online. Im just using the stock fan.
  4. Glad you figured out the issue. Now that you know that the CPU is the issue I would seriously think about upgrading. You will get sooo much more performance from you 680 if you get a new 3570k or 8350, around 20-30 fps improvement.
  5. cpu bottleneck for sure. An fx6300 would be a good cheap upgrade, but will still bottleneck that card in some situations.
Ask a new question

Read More

Nvidia Gtx Graphics