Sign in with
Sign up | Sign in
Your question

Crossfire not working with Crysis 3

Last response: in Graphics & Displays
Share
March 1, 2013 4:59:39 PM

The thread title pretty much says it all. I've already played thru the entire game before I realized crossfire wasn't working. One 7950 gave me playable frame rates at 5760x1080. (High Settings with 2xaa I think). I started up MSI afterburner on my fourth screen though and notice that while playing my second GPU is at idle. Anyone know how I can get crossfire working in the game. It works well for the other games I've played lately (verified working in sleeping Dogs, Battlefield 3 etc...). I'm running 2x Sapphire 7950's (One OC edition, one Boost Edition). I was using Catalyst Beta 13.2.6 but upgraded today to 13.2.7. Still no change, second GPU sits at idle when I play Crysis 3. Any suggestions?
March 1, 2013 5:17:16 PM

Hi,

I would imagine it'll be a driver issue as Crysis 3 is a fairly new game, crossfire support usually takes awhile to get going with new releases.
m
0
l
March 1, 2013 5:41:41 PM

Rolling back to the previous beta seems to have fixed it. Strange but its working, thanks anyway.
m
0
l
Related resources
March 1, 2013 5:42:39 PM

AdioKIP said:
Rolling back to the previous beta seems to have fixed it. Strange but its working, thanks anyway.


Glad you got it working, Enjoy ;) 
m
0
l
March 3, 2013 5:12:34 AM

which one did you rollback to? the 13.2 beta 5?
m
0
l
March 5, 2013 2:29:55 PM

Rolled back to 13.2 beta 6 I think (from Beta 7). Will have to double check when I get home to be sure.
m
0
l
!