Sapphire 7950

I just bought a Sapphire 7950 graphics card and I am getting a weird mirage looking effect randomly on my screen kind of a random squiggly mirage effect that makes text, things on the screen, etc jittery.(if that makes any sense lol).... I only had room in my case to have like half a inch of room from the fans of the card to the bottom of the case. But Idle my temps are around 30C and under 100% load they stay around 65-70C. So I dunno why this is happening?

The mirage effect happens almost constantly and randomly on the screen when the computer is idled or doing anything except playing games. I have not see it happen in a game yet.

Anyone have any idea what it could be?
9 answers Last reply
More about sapphire 7950
  1. Hmmm, it seems that it might only do it when my card is in idle mode? Whenever it is running at a faster gpu and memory clock it does not happen.....
  2. That could be alot of things.Dying monitor?Maybe some weird power source that causes it?Not sure can you move your pc a few feet to see if it still does it.really it could be about anything.
  3. I would say maybe the psu but if its not doing it in game i doubt thats the issue.
  4. I think it has to do with flash adds. I had the same issue and once I got adblocker the whole thing stopped. I also remember someone commenting before saying it had to do with corrupt mouse effect, google it. So far I know that it's due to flash because when I disable adblock on chrome, I get the jittery effect now and then but when I have it on, it never happens. So try that and see.
  5. It does it when my computer is just sitting at desktop with literally nothing open....

    AMD Phenom x6 1055T 2.8 GHZ

    4 GB Ram

    Power supply is 700w.
  6. That's weird then. Did you just make this PC? If so, did you have a different GPU in it or not?
  7. It was running fine when I had my 5770 in it. Just upgraded today and put the 7950 in. I can pretty much confirm that when it idles at 300mhz GPU and 150 mhz memory clock it instantly starts doing it.

    But when I start a game and it goes to 925 mhz GPU clock and 1250 mhz memory clock the problem is no longer there.
  8. I think I might of found the answer here...


    http://www.wsgf.org/forums/viewtopic.php?f=66&t=22189&start=10


    Going to give it a shot.
  9. Bleh. Having trouble setting the idle clocks to a higher number.
Ask a new question

Read More

Graphics Cards Cases Sapphire Graphics