Sign in with
Sign up | Sign in
Your question

Amd 6850 not displaying

Last response: in Graphics & Displays
Share
March 2, 2013 12:27:14 PM

This is a brand new card i just bought about 3 to 4 months ago. It worked just fine, then i upgrade to a new mobo, cpu and ram every since then the video card wouldn't display unless i unplugged it and plugged it back in then cut on the pc. I have to do this every time. I thought it wasn't enough power but i just bought a 700watt psu yesterday(Had a 500watt before) and its still doing the same thing. I have checked many threads but no solution for me.

Specs:
Amd 6core Phenom
4gb ram ddr2
Windows 7 ultimate x64
MotherBoard Foxconn A7DA-s (not rev3.0)
XFX Amd Radeon 6850
700watt ocz modXsteam-pro

More about : amd 6850 displaying

March 2, 2013 12:38:28 PM

Shut down the pc then unplug ur gfx card and plug it back on and connect all 6 pins > start the computer then restart ...what do you see?
m
0
l
March 2, 2013 12:43:47 PM

It starts regular. first the bios screen goes thought all that stuff the usual and then it proceeds to boot into windows 7. I also get my one short beep which means that it was a good post.
m
0
l
Related resources
March 2, 2013 12:55:21 PM

are you getting display after restart ?
m
0
l
March 2, 2013 1:03:53 PM

Yes but as soon as i cut it off completely i have to unplug the video card and plug it back in for it to display.
m
0
l
March 2, 2013 1:14:39 PM

deathmine said:
Yes but as soon as i cut it off completely i have to unplug the video card and plug it back in for it to display.
''cut off completely '' you mean switching off from the power source ? btw does the monitor shows no signal or completely black screen ?
m
0
l
March 2, 2013 1:24:02 PM

No not the power supply just the computer. And the monitor shows no signal as if it was on stand by. Like your computer was off.
m
0
l
March 2, 2013 1:30:35 PM

deathmine said:
No not the power supply just the computer. And the monitor shows no signal as if it was on stand by. Like your computer was off.

do you have any problem with the onboard graphics ? can you disable the on board graphics from bios ?
m
0
l
March 2, 2013 1:38:18 PM

No and idk how to disable them. What would that do?
m
0
l
!