Sign in with
Sign up | Sign in
Your question

Linux newbie here...

Tags:
  • Windows 98
  • Hard Drives
  • Linux
Last response: in Linux/Free BSD
Share
February 15, 2002 1:48:16 AM

Hi everyone!

As the subject says, I'm a Linux newbie, and I recently installed RedHat 7.2 on the same hard disk as Windows 98 SE. Everything is fine for now, except for one thing: I'd like to access the files on my Windows partition while I'm in RedHat, but I really don't know how! Is there a specific path to access it?

Thanks a lot!

More about : linux newbie

February 15, 2002 5:48:03 AM

Hi! :-)

Did it set a path up at install time? If it did, "C: drive" is likely to be /mnt/windows. If it didn't, the RedHat online docs can step you through it pretty easily.
February 15, 2002 11:58:46 AM

Ok, I got what I was looking for. Thanks!!
Related resources
February 15, 2002 2:05:00 PM

Woops, already got another problem :) 

This time I'm simply looking for the file "pppd" so I can finally connect to the Internet in Redhat. Everything else seems to be fine, only this file seems to be missing. I've been looking for it on my RedHat CDs and on its website, but with no luck. Help, anyone?

Thanks in advance!
February 16, 2002 12:54:45 AM

It normally lives at /usr/sbin/pppd, and is part of the ppp package. I'd be surprised if it is missing, but you might need to be root to run it. As you are a "newbie", I'd suggest using the GUI tools to get the modem+internet going.
February 17, 2002 5:35:54 PM

Thanks for the help poorboy!

Root is the only account on my machine for now, so I doubt that's the problem... I've tried the GUI tools, but I couldn't get them to work with my ISP...

I got my ISP's instructions here, maybe you'd see something I'm doing wrong... <A HREF="http://www1.sympatico.ca/help/local/bell/hsedownloadsli..." target="_new">http://www1.sympatico.ca/help/local/bell/hsedownloadsli...;/A>

Everything goes OK until I try to "run the connection" (the file "start-pppoe", it still says that the file pppd doesn't exist. I downloaded "ppp-2.4.1b2.tar.gz", which should be including it, but I couldn't get to intall it in RedHat... So I tried to extract it in Windows, using WinRAR, but with no luck, the file "pppd" wasn't there...

And I tried installing every Internet related package that came with my RedHat CDs, still without luck... Maybe something screwed up during the installation and I should reinstall it?

I know, I probably sound like a real incompetent... Sorry! Anyway, thanks a lot for helping me!
February 17, 2002 8:56:16 PM

First off, you should get another user account other than root. You can seriously f*** up your system as root if you don't know what you're doing.

See if you can find pppd in your /etc/init.d/rc.d (or is it /etc/rc.d/init.d? I've switched to Debian :)  ) directory. It is a daemon, and that is usually where they are in RH.

With the tar.gz file, unzip it with "tar xzvf ppp....", then read the README. It will give you instructions to install the script (usually going to directory and running "make", and "make install")

Best of luck.

"If you teach a child to read, then he or her will be able to pass a literacy test" - George W.
February 17, 2002 10:16:42 PM

Thanks for the help, gonna try this asap!
February 18, 2002 2:21:54 AM

In RedHat 7.2, it definately should be /usr/sbin/pppd.

Type "rpm -q ppp" and see what it says. If it's not installed, download it from <A HREF="http://www.rpmfind.net//linux/RPM/redhat/7.2/i386/ppp-2..." target="_new">here</A> or get it off your cdrom, and "rpm -ivh ppp-2.4.1-2.i386.rpm" to install it. To verify things went ok, type "rpm -q ppp" again, and then "which pppd" to check it's in the right place. You'll need to be root for this.

Plan B is to compile the tar.gz file. Something like:
tar -zxvf ppp-2.4.1b2.tar.gz
cd ppp
./configure
make
make install (as root)

This 2nd option may be a small can-o-worms as you need to have installed the development libraries and compilers. Not hard, but it's more stuff to do if they're not already there...
!