Sign in with
Sign up | Sign in
Your question

Adding two WLAN access points to existing network

Last response: in Networking
Share
April 11, 2012 9:29:23 AM

Hey now.

Here's the deal. My internet provider provided me with a shitty router with a lot of settings locked. I can't change DHCP settings or add custom static IP addresses. This sucks. The wireless function on it sucks also.

I added an extra router to the network so I have good Wifi in my living room. I turned off the NAT, firewall and DHCP on that one, so it's a simple switch with a wireless access point now.

Now here's the deal. The DHCP server of the provider's router hands out IP's from 192.168.2.1 to 192.168.2.253 (192.168.2.254 is the router's own IP address).

I gave the added switch/access point the IP address 192.168.1.1 in its own settings. The original router doesn't 'see' the switch now anymore because it's out of the DHCP's range. When I gave it an IP address within the DHCP's IP range, I got all kinds of conflicts (as expected).

I guess this is a solution since it works, but I'm open to other suggestions since it doesn't seem to be the best way of doing things. Besides, I can't access the access point's web interface anymore since it doesn't have an IP address within the network now. It isn't important because I don't need to change any settings anymore, but still.

I'm going to add a second wireless router to replace the built-in wireless function of the provider's router. For some reason it sees its own wireless network as a separate network or something. When I roam from the new access point wifi to the provider router's wifi, everything gets confused because it tries to give the laptop a new IP address.

The provider's router doesn't discriminate wireless and wired LAN when devices are connected through the second access point.

I hate wasting money and time on bullshit like this. I'm pissed off that my provider treats me like some asshole who doesn't need access to all the functions of a device I paid for.
April 11, 2012 11:34:54 PM

What device did they give you? Often you can disable the router function of it, and just use it as a normal cable modem. It's usually not a straight forward change to do so, but if you google I bet you come up with how to do it. Generally its going to a page you can't get to from the interface of the router, but if you know the actual page you can go directly to it. I know the twc UBEE devices work this way, and would think most others have something to sort this out as well.
April 12, 2012 12:44:27 PM

You must assign the router an IP (manually) inside the pool being issued by the ISP router. Any conflicts that may occur will probably be from connected devices on the network, so you should restart the ISP router after assigning your router the new address. I suggest assigning an address like ....2.253 because the DHCP will be issuing addresses starting from 1.
You did well by disabling NAT, DHCP and FW they would only cause you problems.
That's basically it, You should be fine!
Related resources
April 12, 2012 11:39:58 PM

Quote:
What device did they give you? Often you can disable the router function of it, and just use it as a normal cable modem. It's usually not a straight forward change to do so, but if you google I bet you come up with how to do it. Generally its going to a page you can't get to from the interface of the router, but if you know the actual page you can go directly to it. I know the twc UBEE devices work this way, and would think most others have something to sort this out as well.


It's a Thomson TG789VN. I really can't get into advanced settings. They locked users out of it. I looked around for hacks and all that, but there is simply no way to do it. No full admin rights.

Quote:
You must assign the router an IP (manually) inside the pool being issued by the ISP router. Any conflicts that may occur will probably be from connected devices on the network, so you should restart the ISP router after assigning your router the new address. I suggest assigning an address like ....2.253 because the DHCP will be issuing addresses starting from 1.
You did well by disabling NAT, DHCP and FW they would only cause you problems.
That's basically it, You should be fine!


I tried that first, but for some reason that gives a conflict. Everything goes haywire when I do that.

I got it working by giving both wireless access points (I bought a 2nd wifi router today) IP addresses outside of the DHCP pool and now it works fine. The ISP router thinks that they're switches and all wireless connected devices are wired. It's a weird solution, but it works great now.

Thanks for the suggestions.
!