Sign in with
Sign up | Sign in
Your question

Win 7 wired - no net connect, no ipconfig, works w/linux

Last response: in Networking
Share
April 12, 2012 11:06:40 AM



Machine is dual boot Win 7 x32 and linux. I'm using a wired Broadcom ethernet card and a cable modem.
Only one computer is connected and I have no router. In the middle of surfing on the Win OS, my connection dropped.
I rebooted to windows and got a red X in the sys tray. No connection, no network connectivity.
I booted again, into Linux this time, and it works fine. So this is a software issue for sure (I would think). At least it's not a problem with the wires or my ISP or anything.

The "Nework and Sharing" screen shows no connection, but the properties screen in the device manager shows it's connected with no problem, although it shows 0 bytes transferred. It also reports no problem with the driver, which is dated later than the only one I can find on the mfg's website.

Most mysterious of all is that running ipconfig/all doesn't show the card at all. It's completely missing.

One of the property screens (I forget which one, but I think it's one of the device manager screens) has the message "Windows couldn't automatically bind the IP protocol stack to the network adapter".
IPV4 and IPV6 show no connectivity.
That's the best and only hint I've gotten so far as to what is going wrong, but I can't find a clue of how to correct it.

The network troubleshooter acts like it is resolving the problem but is useless in the end and just reports that my network card is "experiencing problems"....Duh!

This is what I've done so far:

Power off/on the modem and rebooted (warm and cold) multiple times.
Did full virus and malware scans
Reset winsock
Reset IPV4 and IPV6 TCP/IP stacks to installation defaults
Cleared and registered DNS cache
Release and renew current IP address
Checked Hosts file for any strange entries.
Uninstalled network card and reboot, cold and warm.
Unchecked IPV6 and both topographical protocols, one at a time, and rebooted after each change.
Uninstalled AVG, Comodo Firewall, Open VPN and Wireshark, all of which were present for a week or more when everything was running just fine.
Spit, cursed, rendered my clothes and tore at my hair. :cry: 
Spent 7 hours on google trying to figure this out.

PLEASE!!! If anyone has any idea what's going on here, please chime in. I have wore out my google finger and have not found anything like what I'm experiencing here. At least most people get something reported in their ipconfig window.
Is it possible for a network card to go bad suddenly and only work on one OS but not the other?
I can't use a system restore because, evidently, the VSS shadow service has been turned off lately.

TIA

April 12, 2012 12:19:34 PM

If it works in linux the problem most likely software related. Have you tried installing a new driver for your NIC?
m
0
l
April 12, 2012 12:25:19 PM

Yep, just did that 30 minutes ago. Still no good on Windows. I'm at my wits end by now.
m
0
l
!