Belkin Router Virtual Servers (Port Forwarding) Stops Working

Hi All,

I am having a constant problem with my router and I can't figure out why it is happening. Please help.

I need to access one of my home devices outside my home network. So I need to setup port forwarding. I did this and I am able to access the device fine. But, it will not stick. I can only access for maybe 20 minutes, then it is blocked. I go back into the router config and it shows the port forwarding is active. I won't make any changes but I will hit Apply. It restarts and then port forwarding works fine again.

The router is a Belkin F5D7234-4 v5 Wireless G. I have CenturyLink DSL with a ZyXEL 660R modem. The modem is in Routing mode. I originally setup the router to be in the DMZ of my modem. Then I removed the DMZ and added the ports I want to forward on the modem to point to the router. Either way, I am able to access the device properly for about 20 minutes.

I am not sure what to do. I will buy a new router if I can't get this going soon. Thanks in advance for any help or suggestions!
1 answer Last reply
More about belkin router virtual servers port forwarding stops working
  1. I gave up trying to fix the issue. I bought a Linksys EA3500 Dual-Band N750 router to replace it. So far I am happy with the results. The WiFi coverage is better than expected and I am not having issues with the port forwarding, at least so far.
Ask a new question

Read More

Configuration Routers Port Forwarding Wireless Networking