Solved

Slow upload speed through router

Hello,

I am having a problem with slow upload speeds through my router. I'm a comcast customer and am paying for 20Mbps download speeds and 4 Mbps upload speeds. Currently my download speeds are fine at roughly 18 to 20 Mbps, but I can only get around 500 Kbps on uploads.

I have a Docsis3.0 cable modem going into ooma (a voip phone device) which then goes into my Linksys WRT400N router. My computer is hard wired to the router. When I just go from the computer through the cable modem, or just go through the cable modem and ooma (without the router) my upload speeds are around 2.5 to 3Mbps which is fine. As soon as I add the router, the speeds drop to 500Kbps. I have also tried the cable modem directly to the router (without omma in the connection at all) and I still get only 500Kbps. So it seems that itdefintely has something to do with the router, but I can't quite figure out where to go from here.

By the way, I did just upgrade the firmware in the router to version 1.0.02.11 but that had no affect on the upload speed (either before or after the firmware upgrade).

Any insights would be appreciated. Thanks!

Edit (4/21/12): Just tested the speeds from another computer through my modem, ooma, router setup only it was done wirelessly through the router and I got upload speeds of roughly 3 Mbps and download speeds of 12Mbps. So this seems to confirm that my issue is with the hard wired computer connection to the router. Again, any insights would be greatly appreciated. Thanks.
16 answers Last reply Best Answer
More about slow upload speed router
  1. Best answer
    In your router admin settings make sure QoS is enabled and set your Upstream (or uplink) to manual. Enter in 40,000 Kbps and then be sure to save your settings. I am a Comcast customer with the same internet plan as you and this fixed my problem with upload speeds through the router. I was getting 1.35mbps and now I am seeing 3.75mbps for upload speeds. Hope this works for you too!
  2. Rittnasty said:
    In your router admin settings make sure QoS is enabled and set your Upstream (or uplink) to manual. Enter in 40,000 Kbps and then be sure to save your settings. I am a Comcast customer with the same internet plan as you and this fixed my problem with upload speeds through the router. I was getting 1.35mbps and now I am seeing 3.75mbps for upload speeds. Hope this works for you too!


    Rittnasty,
    Thank's for your reply. This worked for me. Why 40,000 Kbps though? I went from 0.2 to 1.97 much better, but I'm paying for 4. Would tweaking this number help?
  3. Rittnasty, Thanks for this! I just adjusted my QoS as suggested and my upload speed on my Linksys e3000 went from 1.4 Mbps to 11.7Mbps!
  4. I simply disabled my QoS and my speeds went from 1.4Mbps to 5.0Mbps (5 is my ISP limit). Thanks!!!!
  5. Rittnasty said:
    In your router admin settings make sure QoS is enabled and set your Upstream (or uplink) to manual. Enter in 40,000 Kbps and then be sure to save your settings. I am a Comcast customer with the same internet plan as you and this fixed my problem with upload speeds through the router. I was getting 1.35mbps and now I am seeing 3.75mbps for upload speeds. Hope this works for you too!


    OMG, thank you, you are a genius, this works GREAT. I have tried everything but nothing worked. From 0.05 to 25MBps.
  6. Rittnasty said:
    In your router admin settings make sure QoS is enabled and set your Upstream (or uplink) to manual. Enter in 40,000 Kbps and then be sure to save your settings. I am a Comcast customer with the same internet plan as you and this fixed my problem with upload speeds through the router. I was getting 1.35mbps and now I am seeing 3.75mbps for upload speeds. Hope this works for you too!


    would this work for att users as well?
  7. alanmeyer said:
    I simply disabled my QoS and my speeds went from 1.4Mbps to 5.0Mbps (5 is my ISP limit). Thanks!!!!


    is this a troll?... i thought QoS is required? o.O
  8. QoS requires rate limiting to be useful. Even if your router doesn't require, it's doing it and attempting to guess at your speed.
  9. I't worker just with a single MB from 2.8 to 3.8 but i need at least 5 so how do i do ?
  10. PolarisBSH said:
    alanmeyer said:
    I simply disabled my QoS and my speeds went from 1.4Mbps to 5.0Mbps (5 is my ISP limit). Thanks!!!!


    is this a troll?... i thought QoS is required? o.O



    Nah, i think QoS (Quality of Service i think) just allows you to spread bandwidth so it probs worked for him due to only one device on the network or something...

    I'm guessing harddd
  11. My_name_is_Jeff said:
    PolarisBSH said:
    alanmeyer said:
    I simply disabled my QoS and my speeds went from 1.4Mbps to 5.0Mbps (5 is my ISP limit). Thanks!!!!


    is this a troll?... i thought QoS is required? o.O



    Nah, i think QoS (Quality of Service i think) just allows you to spread bandwidth so it probs worked for him due to only one device on the network or something...

    I'm guessing harddd


    Well your somewhat close. QoS is Quality of Service and yes your Internet will work without it. This is for more advanced users as it gives the user the ability to control the "quality of service" (or bandwidth) of a device connected to the router. For example I have 2 devices connected and one of the devices is using a lot of bandwidth by default making the device I'm using slow. How do you fix this? Well you control the bandwidth and you more or less give the device your using more priority. So when you are using it, the router will move (if it can) all your bandwidth and connection stability to that device. Hope this makes some sense idk if it's possibly scrabbled.
  12. paullatta said:
    Rittnasty said:
    In your router admin settings make sure QoS is enabled and set your Upstream (or uplink) to manual. Enter in 40,000 Kbps and then be sure to save your settings. I am a Comcast customer with the same internet plan as you and this fixed my problem with upload speeds through the router. I was getting 1.35mbps and now I am seeing 3.75mbps for upload speeds. Hope this works for you too!


    Rittnasty,
    Thank's for your reply. This worked for me. Why 40,000 Kbps though? I went from 0.2 to 1.97 much better, but I'm paying for 4. Would tweaking this number help?
  13. paullatta said:
    Rittnasty said:
    In your router admin settings make sure QoS is enabled and set your Upstream (or uplink) to manual. Enter in 40,000 Kbps and then be sure to save your settings. I am a Comcast customer with the same internet plan as you and this fixed my problem with upload speeds through the router. I was getting 1.35mbps and now I am seeing 3.75mbps for upload speeds. Hope this works for you too!


    Rittnasty,
    Thank's for your reply. This worked for me. Why 40,000 Kbps though? I went from 0.2 to 1.97 much better, but I'm paying for 4. Would tweaking this number help?
  14. I am a comcast customer. Still leasing their router. When I go to 'router administration site' the options are limited. No QoS options...nada! But, I was desperate, since my upload was at 0.65 (emphasis on that decimal point =( ... ) Anyhoot, I went ahead and did a factory reset on the router. Crossed fingers: totally cleared it all up. No laggy internet. Upload right back up to 12 POINT something or other.
    If it helps....??? Good luck!!!
  15. Rittnasty said:
    In your router admin settings make sure QoS is enabled and set your Upstream (or uplink) to manual. Enter in 40,000 Kbps and then be sure to save your settings. I am a Comcast customer with the same internet plan as you and this fixed my problem with upload speeds through the router. I was getting 1.35mbps and now I am seeing 3.75mbps for upload speeds. Hope this works for you too!


    I have 3 settings under QoS configuration, which one shouls i enable
    1.QoS global configuration
    2.Qos classification
    3.QoS Queue config
  16. ugh not to be a douche but my download is 80 mbps and upload is 5 mbps which in comparison is terrible, how do my upload to at least 15?
Ask a new question

Read More

Routers Modem Cable Computers Networking