Sign in with
Sign up | Sign in
Your question

Windows 7 networking and homegroup

Last response: in Networking
Share
April 24, 2012 2:08:24 AM

HI Everyone,

So my exact problem is this.

I have 3 PCs using Win7 64 bit, one is the home server with all the media on it, two work PCs, at one point Homegroup worked fine and all pcs could see the shared drivers on each computer and share delete etc everything as was intented, one day it all stopped working.

There are two hdds on the media PC, route of the drives shared.

The work PCs each have one entire HDD shared, they are set up correctly, permissions set for all with total control, as far as I can see.

Right now, I have deleted all the homegroup connections and try to set it up again, homegroup is set up on the media PC and that would serve as the host, the other computers cant connect to that homegroup using the password, says there is a homegroup error.

I have tried many of the online fixes, such as starting and stopping the homegroup services and the network mapper services, they seen to not work.

I am running bitdefender 64bit 2012 on all 3 computers, (each computer is allowed access to the other through the firewall) the router is wireless TP link WR841N and each of the PC is using a wireless pen WN721N.

If I try and access files on the media PC right now from my work PC, a dialogue box opens asking for a user name and password, which is odd as there are no usernames and passwords associated with any of the PCs, there is only the admin account and no password for each PC. I can see the PCs on the network and I can usually access the public folders, though not always. The advanced sharing options on each PC are set for newtork discovery on, password sharing off, public folders on, manage homegroup itself on.

At one point all this worked seamlessly, and now it is giving me no end of problems, all i want to be able to do is send and recieve files from the server PC, I dont care about homegroup and all that stuff, jut simple newtorking, see my share driver and take/delete things from them.

Thanks.
a b $ Windows 7
April 25, 2012 10:15:23 PM

To share in Windows 7 within the same workgroup you need to set the permission two places -- in the sharing tab and in the security tab. In the security tab you can just add a group called Everyone and then all users on the workgroup will have access. You can set the level of access to read only, or read/write/modify. Just right click on the drive or folder that you want to share and make the changes under both the sharing and security tabs.
m
0
l
April 26, 2012 1:52:54 AM

As I mentioned in the original post, all the permissions on the shared HDDs are already set up correctly, i.e. everyone with total control.

The problem seems to be more specific and odd than permissions.
m
0
l
Related resources
a b $ Windows 7
April 26, 2012 2:09:01 AM

"permissions set for all with total control, as far as I can see."

My point was that in addition to setting the permissions under the sharing tab you must also create a group called Everyone under the security tab -- you didn't mention that you have done so.
m
0
l
April 26, 2012 2:39:11 AM

I see what you are saying, in the security tab I am adjusting everything to full control, however you say I must create a specific group called everyone? or if I adjust the settings on the groups which are there that would be enough?

For instance the groups in the security tab are:

Administrators
Users
authenticated users
System

Do I somehow need to add to this? As I havent in the past, I havent even really played around with these permissions in the past and it did all work at one point! Share drives viable and accessible by all on the network.

Thanks.
m
0
l
April 26, 2012 2:42:34 AM

can get into the pc and see the public folders, but everything else is locked out.
m
0
l
a b $ Windows 7
April 26, 2012 12:17:55 PM

Yes, exactly -- in the security tab, edit and create a new group called Everyone and give them all privileges (read/write/modify) and that will fix the issue. It's just a little quirk of 7 -- took me weeks to figure it out on my own the first time.
m
0
l
!