Sign in with
Sign up | Sign in
Your question

Alfa AWUS036H Windows 8 Driver

Last response: in Windows 8
Share
February 9, 2013 9:47:23 AM

i want driver alfa windows 8
a b \ Driver
a b * Windows 8
February 9, 2013 10:57:24 AM

the windows 7 driver works use that
m
0
l
March 27, 2013 11:10:37 PM

ksthangal said:
i want driver alfa windows 8


m
0
l
Related resources
August 18, 2013 5:11:52 PM

ksthangal said:
i want driver alfa windows 8


m
0
l
January 18, 2014 3:17:09 PM

mcnumpty23 said:
the windows 7 driver works use that


the windows 7 driver causes my computer with 8.1 to crash to the blue screen saying bugcode_ndis_driver over and over (need a fix)
m
0
l
June 26, 2014 11:11:29 AM

mcnumpty23 said:
the windows 7 driver works use that


It's not my solution - the W7 driver doesn't work (I used the provided disk and selected W7) in mh Toshiba Satellite with 8.1


There doesn't appear to be a driver update on their site, either: http://www.alfa.com.tw/download_show.php?combo_0=&combo...
m
0
l
July 11, 2014 12:30:03 AM

bought this adapter from amazon for my windows 8.1 laptop to connect to a public hotspot available at a bar across the street from my place. the cd that comes with it wouldn't let me install the wifi utility, but the windows wifi utility recognized it (after downloading window 7 drivers manually). however... the connection speeds we unreliable and inconsistent. i couldnt stream youtube vids or load pages reliably.

i've been searching for drivers (for win 8.1 (64bit) for it for the last 2 days, without luck.

i was about to admit defeat and accept that this adapter wouldn't work "correctly" for win 8.1, but as a last ditch attempt, i searched for drivers for "realtek rt8187 wireless 802.11 b/g" instead of "alfa wireless" drivers.

found this:

http://download.cnet.com/Realtek-RTL8187B-Wireless-802-...

downloaded and installed... FIXED the problems i was having.


i was about ready to return this wireless adapter to amazon. now. I LOVE IT!


hope it works for you too.

----------
UPDATE:

i thought things were resolved, but after windows updated last night... the problems began again.

connection/internet speeds were going for normal to NOTHING, just like they were before.

after more searching for an answer, i read on another forum that someone went to realtek's site here:

http://www.realtek.com.tw/downloads/downloadsView.aspx?...

...and installed the Beta package for RTL8187L 1316(Beta) 2011/2/23. <---- be sure to check the date AND version "1316"

*make sure you uninstall the previous drivers you've tried before installing ^this one.


everything seems to be working great again!


once again, i am doing this on a dell laptop that's running windows 8.1 (64bit).

what a pain in the arse this has been! good luck guys.


m
0
l
!