WRT160N Slow download wireless frustration

So I have had a WRT160N for a year and it has worked just fine. I then began transferring files over the network and was trying to tweak settings to get the fastest speeds between computers. Something broke and I can't figure out what happened! I have reset the router multiple times to no avail.

Connected via ethernet to router I get 8mbps down and 1 up, over wireless I get .5 down and 1 up. I have no idea how to fix this. I have tried different channels etc. I have internet through Comcast and my cable modem is sb5101.

Has anyone had a similar problem? This isn't a matter of tweaking settings and getting rid of interference, it is most definitely some software problem (upload speeds are unaffected and speeds are consistently .5 throughout the house). I should have just bought a new router this morning (5 hours ago).

Thanks
-BTM
6 answers Last reply
More about wrt160n slow download wireless frustration
  1. Sometimes, in the heat of frustration we don't allot the time needed for a proper reset to occur.

    A true hard-reset on the router would be pushing the reset button in with a pin or paper-clip for about 15-20 secs, waiting till the light flashes, blinks a few times, and then completely disconnect all sources of power to the router. Hold in the reset switch again to completely dissapate the power, and after waiting about 2-5 min ....plug it back in.

    After you know you've done this correctly , and still have problems, i'd focus more the chance that you may have changed a setting on the computers themselves.
  2. Thanks, I did a hard reset (30 secs with reset pressed, 30 powered off with reset pressed, a few minutes unplugged, power on with reset pressed). I am still getting horrible speeds. I don't think I have changed any setting on the computers to cause this because ones I haven't done anything too are slow as well. My phone gets 1mbps down but that is using the speedtest app so that could explain some difference and is still not the full 8mbps.
  3. [SOLVED?] So it turns out there is a problem with wireless-N. The changes I made had been to change from wpa to wpa2 (wpa does not get faster than G speeds, wpa2 lets you be faster). The faster local speeds somehow messed up the router's ability to give normal download speeds. I changed the router to be 'g' only and the problem is solved. I wish I could have the faster speeds though for local traffic.
  4. I can say that in my experience, I've seen wierd things happen when adjusting my router to " N-only" mode, but bear in mind that this would only affect wireless traffic, and that any device not capable of "N" wouldn't connect.

    I honestly don't know if wpa vs wpa2 would make your Download speeds slower, Wpa is considerablyl less secure than Wpa-2, and ify ou're going to use that encryption standard, shoot for the stars and use AES encryption method.

    When you say "Local" traffic, I'm assuming you mean internal wireless traffic or is one your pc's wired, because honestly, the Wireless mode should never affect wired speeds off of the built-in switch on the back of that linksys box ( btw...I'm not a fan of Linksys).

    It honestly sounds to me like you either need to update the firmware on that router, or change your wireless channel, to rule out interference.

    Again, the details thus far are albeit sketchy. Just curious what consists of your network besides the 2 pcs?

    Also, I vote for a new router. Belkin is decent, so is netgear.
  5. I have 4 pcs running windows 7, all have N. I also have 2 android phones, not sure the wifi for that, and a few ipods/iphones. Everything is wireless.

    Regarding wpa slowdown: http://www.smallnetbuilder.com/wireless/wireless-basics/30664-5-ways-to-fix-slow-80211n-speed (item 4)

    I tried different channels with no luck, I think the firmware just needs an update, but none are available :( I will just sit on it until my needs are greater. Thanks for the reply.
  6. In the config page under wireless, make sure you've got manual settings selected.

    Wireless mode : Mixed
    Radio band: Standard 20MHZ
    Channel 6

    Wireless security - WPA2 Personal
    Encryption: AES


    Advanced Wireless- Auto everything

    Ap isolation: Disabled
    Frameburst : Enable

    Applications and Gaming -
    QOS: enable make sure WMM is enabled as well.
    Everything else disable or auto

    Basic Setup -

    Everything Automatic:

    Advanced routing:
    Nat: Enabled
    Everything else Disable or Auto


    Security * not wireless secruity*

    SPI Firewall: Enable
    Filter Anamyous internet requests: enable
    Filter indent port 113 enable:

    Web filter: Clear all these options if checked


    Additionally if you still can't get this resolved, I would try flashing this things firmware with an open source solution such as

    http://www.dd-wrt.com/site/support/router-database

    Note* make sure you read the instructions and ensure your router is supported - I've fried a router or two becuz my revision wasen't on the supported list.
Ask a new question

Read More

Routers Wireless Networking