Sign in with
Sign up | Sign in
Your question

Tivo man logo on front of new Tivo Series 2 not sticking

Last response: in Home Theatre Legacy
Share
Anonymous
July 18, 2005 3:52:43 PM

Archived from groups: alt.video.ptv.tivo (More info?)

The raised plastic Tivo man logo on the front of my new Tivo series 2
had come un-stuck from the front of the unit before I received it. It
was lying unattached in the plastic bag surrounding the unit when I
opened it. It has some "stick" left on it, but falls off after a few
seconds. The front of the unit of course looks like there is something
missing without it, and you have to have the logo light turned off,
otherwise you have a bright light coming though the front right at your
eyes. Calling Tivo they offered to exchange the whole unit, as I guess
they can't get a replacement logo from their actual manufacturer.
Sending the unit back and setting up another seems like a whole bunch
of cost and hassle (for both of us) for such a simple problem. Soooo,
has anyone else had the same problem, and has anyone found an
appropriate glue to re-stick the Tivo man logo?

Thanx
Bob
Anonymous
July 18, 2005 7:24:15 PM

Archived from groups: alt.video.ptv.tivo (More info?)

Yeah, there's an opening (clear) in the white frosting behind the front
panel which lights the Tivo logo. If it wasn't there (completely
frosted white), there would be no problem, just an indentation where
the Tivo logo goes. Without the logo in place, with the logo light even
in dim, you get a blast of light through the break in the frosting.
Anonymous
July 18, 2005 7:24:44 PM

Archived from groups: alt.video.ptv.tivo (More info?)

Yeah, there's an opening (clear) in the white frosting behind the front
panel which lights the Tivo logo. If it wasn't there (completely
frosted white), there would be no problem, just an indentation where
the Tivo logo goes. Without the logo in place, with the logo light even
in dim, you get a blast of light through the break in the frosting.
Related resources
Anonymous
July 18, 2005 8:36:07 PM

Archived from groups: alt.video.ptv.tivo (More info?)

"Bob Scola" <scola@scn.org> wrote in
news:1121712763.840388.61440@g14g2000cwa.googlegroups.com:

> The raised plastic Tivo man logo on the front of my new Tivo
> series 2 had come un-stuck from the front of the unit before I
> received it. It was lying unattached in the plastic bag
> surrounding the unit when I opened it. It has some "stick" left on
> it, but falls off after a few seconds. The front of the unit of
> course looks like there is something missing without it, and you
> have to have the logo light turned off, otherwise you have a
> bright light coming though the front right at your eyes. Calling
> Tivo they offered to exchange the whole unit, as I guess they
> can't get a replacement logo from their actual manufacturer.
> Sending the unit back and setting up another seems like a whole
> bunch of cost and hassle (for both of us) for such a simple
> problem. Soooo, has anyone else had the same problem, and has
> anyone found an appropriate glue to re-stick the Tivo man logo?
>
> Thanx
> Bob
>
>

I posted here a few months back asking why after a recent upgrade the
light got brighter despite being set on dim. It was my wife who
noticed the logo had come unstuck and thus the light was a lot
brigher. Duh! I have only tried Zap-a-gap and didn't work. I am sure
some other rubber glue will though. For now the light is off until I
get around to fixing it.
Anonymous
July 18, 2005 11:59:16 PM

Archived from groups: alt.video.ptv.tivo (More info?)

Personally, I'd just leave it off.

Any reasonable adhesive should stick the little guy back on. I'd
probably try Duco cement or something like that.

In article <1121712763.840388.61440@g14g2000cwa.googlegroups.com>, Bob
Scola <scola@scn.org> wrote:

> The raised plastic Tivo man logo on the front of my new Tivo series 2
> had come un-stuck from the front of the unit before I received it. It
> was lying unattached in the plastic bag surrounding the unit when I
> opened it. It has some "stick" left on it, but falls off after a few
> seconds. The front of the unit of course looks like there is something
> missing without it, and you have to have the logo light turned off,
> otherwise you have a bright light coming though the front right at your
> eyes. Calling Tivo they offered to exchange the whole unit, as I guess
> they can't get a replacement logo from their actual manufacturer.
> Sending the unit back and setting up another seems like a whole bunch
> of cost and hassle (for both of us) for such a simple problem. Soooo,
> has anyone else had the same problem, and has anyone found an
> appropriate glue to re-stick the Tivo man logo?
>
> Thanx
> Bob
>
!