Sign in with
Sign up | Sign in
Your question
Solved

XP to Win7 Frame rate drops

Tags:
  • World Of Warcraft
  • Windows 7
Last response: in Windows 7
Share
February 4, 2010 10:15:48 PM

I have this posted in several forums, because I dont know what is causing problem.


Hey Everybody,
First time here, hope you can help.
My system:
Asus A8n SLI deluxe
AMD 64 400+ 2.4 gig
OCZ DDR400 2 matched pairs total 4 gigs
Rosewell 600 watt dual 12v rail 19 amps each.
Evga 8800gt
Asus 24" wide screen 1900x1080
WD 130 gig raptor
HT/Omega sound card.
Win 7 Ult. 64

My main problem is that When I switched over to Win 7 my frame rate drop over half when I play WOW. I have tried several different drivers.Tweak force, Nivida Beta and current released, plus an older one that is in Win 7. Just cant get it to go up. I switch back to XP(on seperate drive) and its back to the high frame rate.
I am looking for several things. 1st what is causing the problem, Can I correct with what I have? If I need to replace parts, what should I replace and with what. I think my video card is ok. I use the system for WOW, Unreal Tourment 3, and the age of Empire series. Plus Digi Photography. I mainly play WOW. I like Nivida and AMD.
I have read it could be driver related or not enough CPU power and mem. WOW is a hog on the resources I am told.
Thanks in advance
Daka

3d Mark score 6008

sM2 2883

SM3 3792

CPU 929

More about : win7 frame rate drops

Best solution

a b $ Windows 7
February 5, 2010 12:33:48 AM

In trying several different drivers, you may not have properly removed the video driver to install the second driver. When you are using a driver you can not properly delete it.

Download your driver, but do NOT install it.
Save it to your Desktop.

Download/install Driver Sweeper (it's free)
http://downloads.guru3d.com/downloadget.php?id=1655&fil...

Boot up into the Safe mode (F8)
This will enable you to boot up using the Windows generic driver.
Run Driver Sweeper

With the Driver Sweeper, delete the video driver.
Close Driver Sweeper and install your video driver.

Reboot as normal.
Share
February 12, 2010 12:00:25 PM

Best answer selected by daka.
m
0
l
!