Sign in with
Sign up | Sign in
Your question

Printing DOS files to a network printer

Last response: in Windows 7
Share
April 3, 2012 1:01:24 PM

Hello,
When I map LPT1: as follows:
Net USE LPT1: \\computername\prinetrsharename /PERSISTENT:YES
it maps and works once or twice and then LPT1 is unavailabe if NET USE is typed in the promptr window. Any solutions?
a c 215 $ Windows 7
April 3, 2012 1:34:20 PM

You need to change a local policy.

Open Group Policy Editor. Select/Computer Configuration/Administrative Templates/System/Logon. Open “Always wait for the network at computer startup and logon” policy and enable it. Reboot after changing this setting.

NOTE: This can slow down your login.
April 10, 2012 1:31:09 PM

Dear Hawkeye22, I have tried what you suggested concerning group policy changes and managed to enable as directed. After restarting my computer I deleted LPT1, using NET USE LPT1: /DELETE. Then I remapped using PERSISTENT:YES as you suggested, having rum the DOS prompt as Administrator. Restarted my computer and checked for LPT1: it was "Unavailable". Please note, after enabling the group policy selection and restarting my computer, in the comment column I still see the word No. Does this mean that although the chosen group policy is enabled it is not in effect?
Related resources
a c 215 $ Windows 7
April 10, 2012 2:16:31 PM

Which comment column are you talking about? If you go back into the policy editor, it should be listed as "enabled" instead of "not configured". Also, you do not need to do a net delete. Use the net use with the persistent flag. Along with the local policy, the system should wait for the network to become available before trying to attach to network devices. If it says unavailable, it usually because the remote computer/device is offline. This seems to happen a lot with printers that go into sleep mode after x minutes of being idle. Not much you can do about that other than to tell the printer never to sleep.
April 10, 2012 3:17:13 PM

1- I have woken up the printer manually by making sure it says ready. The LPT1: is still unavailable.
2- The following is the line in the Group npolicy editor that I see:
Always wait for the Network at computer startup or logon. To the right of that and under a tabulated heading is "State" and it says "Enabled" to the right of that on the same line under the heading "Comment" is the word "No". is there a way I can copy an image of the page and send it to you?
a c 215 $ Windows 7
April 10, 2012 5:00:01 PM

Ah, I don't have a comments column, just the state. As long as the state is reading enabled, it's good. I think the comment is just showing you the default state if it's set for "not configured".

Is the computer the printer is attached to going to sleep or possibly sending the usb ports to sleep?

Other than that, I don't see what the problem can be, especially if the connection is initially established and you can print to it ok. every time I've run into this, either the share wasn't set up properly or the remote computer/printer was offline or asleep.
April 19, 2012 11:22:57 AM

Dear Hawkeye22, I was away from my desk all last week. Alas, this problem remains unresolved. If you hear of a solution anywhere, please send me a line or direct me to the location where I may find an answer. Thanks for all your help.
!