Sign in with
Sign up | Sign in
Your question

BSOD While installing SP1

Tags:
Last response: in Windows 7
Share
April 3, 2012 6:38:10 PM

So I recently built a new computer and Im having a problem installing Service Pack 1 for windows 7.
I got Windows 7 Ultimate through my College on a discount but Ive been running into a stream of problems.
Firstly it didn't like the my product key. I had to contact Microsoft several time about it until the college finally gave me a new key.
Secondly I tried to install the Service Pack. However when It reboots windows and give you the "Configuring Windows" setup it Blue Screens and crashes at 71%. Every time.

Im running two hard drives on this desktop. One SSD 128gb and the other is my primary storage. a 300gb 7200 WD.

Specs are as follows.
Motherboard: ASUS Sabertooth 990FX
CPU: AMD FX-6100 3.6GHz
RAM: 8GB G-Skill GDDR3 1333mhz
GPU: AMD HIS Radeon 6870 1GB
OS HDD: 128gb Plexar Solid State Hard Drive
Storage: 300gb WD 7200rpm

Many thanks in advance.

More about : bsod installing sp1

April 3, 2012 6:51:22 PM

What's the BSOD error code?
m
0
l
April 3, 2012 6:54:16 PM

The code is 0x000000f4

Edit:
Also worth noting that I ran the system in safe mode, it noticed that the service pack failed to install and simply reverted the changes back. Then restarted.

After it restarted I let it boot back to windows normally and it again, gave me a Failure Configuring Service Pack message and that it was Reverting Changes.
So I waited for it to revert but it happened to BSOD on me again. Same error code.

Let it once more reboot back to Windows and it just repeats the process...

Also note worthy that the system ran fine before. Never had a BSOD on it.
Just built it about 4 weeks ago and realized that SP1 wasn't installed. So I decided to throw it on and now its doing this.
m
0
l
Related resources
a b $ Windows 7
April 3, 2012 6:57:59 PM

I would be running memtest over night.
m
0
l
April 3, 2012 7:00:26 PM

Agreed. That bugcode means that something killed a critical system process which forced a shutdown. The process was likely killed because it read some corrupt data from RAM and tried to do something with it which caused it to throw an exception and die.
m
0
l
April 3, 2012 7:03:59 PM

How do I run a memtest when I cant even get into safe mode?
Once I start Windows it wants to revert the Changes from the Service pack.
I wait for a bit but after awhile it just Blue Screens.

Update: I managed to get it into safe mode w/o networking.
Btw: Im on my laptop at the moment in case you are confused on how Im doing this.

UPDATE 2: After I managed to get it to safe mode without networking I restarted the system again and let it run windows normally.
works fine now. Of course I got a error that says the Service Pack was not installed properly.
Ill let the system run some memory test. See if there is a problem.
m
0
l
April 3, 2012 7:12:14 PM

On another computer, download the USB autoinstaller tool from memtest86.org, run it and install memtest86 to a USB drive, then boot that USB drive on your problematic computer. If it completes a few passes, it's probably ok, but to be safe, let it run overnight. If it finds any errors, you'll need to do figure out if it's your motherboard or your RAM (or your CPU if you're profoundly unlucky).

EDIT: You can run the Windows Memory Diagnostic tool since you're in Windows instead of having to download memtest86 (might still be a good idea though, but run the Windows test first and report back here with the results)
m
0
l
April 3, 2012 7:20:57 PM

ok thanks. I gotta run to class till 5. Letting Windows Run its memory diagnostics tool.
Ill report back any problems.
m
0
l
April 4, 2012 1:32:48 AM

Memory Diagnostics didn't find any errors.
and Memtest86+ after 2 passes hasn't found any errors. Ill keep it running for a few more hours. See if it finds anything.
m
0
l
April 4, 2012 2:09:26 AM

Update:
I actually just system restored to before Installing SP1. Thankfully Windows is smart enough to set a restore point before installing the service pack. So I didnt loose anything. Seems to be working fine.
I think in the mean time Ill hold off on SP1 for awhile, until I figure out what went wrong.
m
0
l
a b $ Windows 7
April 4, 2012 12:42:10 PM

Just to be safe, run Prim95's blend test. If that passes, we can rule out RAM.

0xF4 can happen due to a variety of reasons, but the root cause is that a process/thread critical to the system shuts down in an unexpected way. It could be as simple as the update process conflicting with some background utility that you are running. [For example, program X assumes system task Y is running; when Windows Update shuts down that system task, program X ends up corrupting the system].

Might want to run sfc /scannow, which will check for any corrupted system drivers. Failing that, if the rest of the system is stable, I'd pass on SP1 until you can figure out what exactly is causing the problem [or install the individual updates one at a time].
m
0
l
!