Sign in with
Sign up | Sign in
Your question
Solved

1 mb transfer rate on Windows 7 home network

Last response: in Networking
Share
May 11, 2012 10:26:02 PM

We had a small home office with three computers, two new desktops with win7 64 and an old comp running Vista32. Up until last week, the two 7's accessed files on the vista machine via a public folder, and everything was peachy, speed-wise.

Trashed the vista this week and replaced it with a new desktop running win7 64. I backed up the old comp's files on the new comp, set up the new win7 home network, and everything went to hell. Both of the 'old' win7 machines can access files on the new, but the speeds are unbearable. It takes, literally, over 10 minutes for Accubid to load (accessing files on the new desktop), whereas it was pretty much immediate before. Quickbooks freezes for a minute and a half before it finally connects. A 60mb PDF file takes two minutes to copy. It even hiccups when I save a freakin' Word document.

After some research I found that window's new home sharing network kinda sucks, so I turned it off on all machines and mapped network drives. Nothing.

I heard it helps to turn off remote differential compression, so I turned it off on all machines. Nothing.

I disabled flow control on all machines. Nothing.

The weirdest thing I did - I disabled auto-tuning and restarted all computers. I then opened Accubid and it opened immediately! I restarted the program 6 or 7 times, and each time it came up within seconds. I was ecstatic.

Then my boss came in 5 minutes later and I opened Accubid to show him I finally fixed it. It took 10 minutes to load again, and I haven't been able to repeat whatever I had done since.

For the love of god, help me.

My ISP is ATT.
Modem - D-Link DSL 520B
Router - Netgear WNDR3800

Network is wired. Again, access to internet is blazing. Access to the computer 6 feet away from me is not.

Best solution

May 11, 2012 11:59:22 PM

are you setup as a Home or Work network?

did you try disabling IP6?
Share
May 12, 2012 2:08:05 PM

try this command on one computer at a time. You will have to reboot after running it.

netsh int tcp set global autotuninglevel=disabled

If it doesn't make a difference, just re-enable it

netsh int tcp set global autotuninglevel=enabled

While it *shouldn't* make a difference, I have had it make a difference. I went from sub 2Mb/s to 1Gb/s

They thing that really confused me is why is also limited my UDP traffic, since it's a TCP setting that modifies TCP flow-control. UDP doesn't even have flow-control.. wtf.
m
0
l
Related resources
May 12, 2012 5:21:11 PM

Emerald said:
are you setup as a Home or Work network?

did you try disabling IP6?


When I first got the new computer up, I had everyone on a Work network (and, I believe, everything worked fine. I'm just now realizing this as I type.) Then I read about the new HomeGroups option on Win7, so I switched to that. Everything started snailing on me, so I had all computers leave the HomeGroup and switched back to work. And I will try disabling IP6!

Kewlx25 said:
try this command on one computer at a time. You will have to reboot after running it.

netsh int tcp set global autotuninglevel=disabled

If it doesn't make a difference, just re-enable it

netsh int tcp set global autotuninglevel=enabled

While it *shouldn't* make a difference, I have had it make a difference. I went from sub 2Mb/s to 1Gb/s

They thing that really confused me is why is also limited my UDP traffic, since it's a TCP setting that modifies TCP flow-control. UDP doesn't even have flow-control.. wtf.


I did disable autotuning on all machines, and that's the most frustrating thing. It worked. For 10 minutes. Maybe I'll switch it on and back off to see what happens?

m
0
l
May 12, 2012 8:16:06 PM

Best answer selected by dankrubis.
m
0
l
May 12, 2012 8:16:50 PM

Emerald said:


did you try disabling IP6?


I love you.

Network is lightning fast once again. Thanks all!
m
0
l
October 16, 2013 8:15:49 PM

To turn it back on after:
netsh int tcp set global autotuninglevel=disabled

use the following instead:
netsh int tcp set global autotuninglevel=normal
m
0
l
!