Sign in with
Sign up | Sign in
Your question
Solved

Bootable USB and Flashing BIOS

Last response: in Windows 7
Share
April 7, 2012 3:35:17 AM

I am trying to update the BIOS of my 'ASrock Z68 Extreme4 Gen3' from v1.00 to v1.20. I am running Windows 7 64bit Ultimate.

I got the BIOS file from:
http://www.asrock.com/MB/download.asp?Model=Z68%20Extre...

It did not register the BIOS file I had put on my USB drive when going to my BIOS settings. There is an "Instant Flash" function in there.
I have tried to make a bootable USB-drive to do it directly from DOS, but my drive can't be formatted as an MS-DOS boot drive.
I have tried using HP DriveKey which seemed to work as intended, but it didn't help me, the drive was still not recognized in bios.

Do you think it's my drive? I don't have another drive with me right now to try it out.

I know this is a not really a Windows 7 issue, but I couldn't find a proper category.

April 7, 2012 4:00:51 AM

I don't know of any windows flash utilities.

Is it a stand-alone program or a part of windows, and if, where?
m
0
l
Related resources
April 7, 2012 4:46:10 AM

It is is a program provided by you board maker. ONLY GET IT FROM THERE. Now adays they embed the windows utilitie in the bios firmware file so its just a .exe so try double clicking the file you downlloaded and see what happens. Note doen't do ANYTHING on your computer while it flashes. This included active background like playing music or antivirus.
m
0
l
April 7, 2012 5:00:34 AM

I will try looking for it, but all i found when browsing the ASrock support site was the bios package itself.

EDIT:
Actually, the link I gave in the parent post is the site I was referring to just now

To me it seems like you should be able to just put it the file anywhere on the computer and then it would detect it with "Instant Flash". It just doesn't
m
0
l

Best solution

April 7, 2012 5:06:06 AM

2 Things, First the flash drive needs to be under 2gb, second it needs to be formatted to FAT. Not FAT32, or NTFS plain old FAT. And since it needs to be in FAT, 2GB is the maximum supported size.

I've heard people say FAT32 works, but my old Gigabyte, MSI and my current Asus seem to prefer FAT. Using FAT it always recognizes it.
Share
April 7, 2012 6:14:44 AM

Best answer selected by AtotehZ. nnI managed to flash through windows, something I really don't like doing as too many things might influence the result.nnEven though I didn't get anything that could solve my problem I'm gonna go with Cliff as the best answer. He reminded me of some of the basics I had forgotten.nnEDIT: Funny observation :p nnAfter the flash the USB drive is detected as a bootable drive in the boot menu, it wasn't before. I wonder if the bios version I had running before was flawed.
m
0
l
!