Sign in with
Sign up | Sign in
Your question
Solved

Marvel SATA3 controller missing!

Last response: in Windows 7
Share
April 7, 2012 6:50:04 AM

I have BIG problems with doing my PC showing the Marvel SATA 3 controller in BIOS. Can see Intels controller for SATA2 port 0-5 but there is nothing at all showing for my two SATA 3 ports on my motherboard. Have flashed BIOS to the latest version 1304 but I cant still not see it. When using the Sandforce Firmware tool I cant see any SSD disc at all, nor can I open the Marvel 91XX tool/program (both programs in Windows). In System in Control Panel my SSD is showed as an SCSI, in BIOS boot meny it is shown as an IDE unit. When booting first my system discs is showing correctly, then it continue with first texting "No viritual disc installed!" and under that its texting "SSD Force GT 120BG", then its continue to boot up. Have downloaded every drivers a coupple of times and Windows is showing "new hardware (Marvel 91XX) found and installed" but I still cant open it or make the PC to detect my SSD as an SSD and not as an SCSI disc! The only way to in fact see that it exist is in boot meny in BIOS and there it is shown as IDE unit. Using RAID option for the SATA2 ports and AHCI for Marvel. Dont understand what the computer means with "no viritual disc installed" when I allready use a small (200 MB) windows viritual memory page file/exchange file connected to my C: HDD system discs and thats working just fine?

Using:
Windows 7 64 PRO
Intel i7 960 3.20 GHz 1366
ASUS Sabertooth x58 socket 1366 motherboard
24GB Corsair Vengeance 1600 MHz DDR3 RAM
2x WD VelociRaptor 74GB HDD SATA2 in RAID 0 as system disc
Corsair Force GT 120GB SSD SATA3 (SandForce Controller) as game disc
Latest drivers (1304 for BIOS and 91xx for Windows) and a SATA3 cable to my SSD connected to port 0 in the Marvel socket on my MB
SysTweak Power Bundle PRO suite

When benchmarking my SSD the highest speed I got was 344/177 MB/s thus the disc should be 555/515 MB/s.

What is wrong? Why does the Marvel controller dont show itself in BIOS? How should it look in BIOS when those 2 ports are showing? If its broken circuits on my motherboard the two Marvel ports should not work at all, or? Dont want to hand in my PC for service and take out the MB = doing everything from the beginning again :sweat:  :( 

Here under is the text from my e-mail support with ASUS and their answer:

"Cant open Marvel controller for SATA 6 Mb/s ports in BIOS or Windows. BIOS is
showing IDE:Corsair Force GT in BOOT meny, in Windows it is shown as a SCSI in
SYSTEM. Cant open Marvel 91XX. There is not showing any SSD disc in Force GT 120
Sandforce Firmware. Can install Marvel controller from the DVD but nothing happens
and it cant open. Tried to download driver but I still cant open or see any Marvel
Controller nor in BIOS, nor in Windows. BIOS v.1304. Use two WD VelociRaptor HDD
in RAID 0 as system disc. Have used the Systek Power Bundle and it have found and
updated Marvel, but it still dont work. How to do to make my PC to see my Corsair SSD
disc as an SSD and not as an IDE/SCSI unit?"

ASUS answer:

"Hi
Try updating to bios version Sabertooth X58 1304 BIOS
if this doesn't help return the board to the store you purchased it from"

PLEASE HELP :cry:  !!!

Best solution

a b \ Driver
a b $ Windows 7
April 7, 2012 8:15:02 AM

Hello DarthTengil;

Have you run this question through the Motherboard section of the forums?
It's looking more like a hardware issue than Windows 7.
Share
April 7, 2012 12:43:44 PM

Hard to tell when its both hardware and software im having troubble with. If any moderator see this and think its posted in the "wrong" forum please put it in the Motherboard forum instead!
m
0
l
April 8, 2012 10:30:04 PM

Best answer selected by DarthTengil.
m
0
l
!