Sign in with
Sign up | Sign in
Your question

IBM Hard Disk Installation Problem

Last response: in Storage
Share
May 22, 2002 5:47:51 PM

Here's one I haven't come across before - maybe some of the boffins out there can help me.

I have a Maxtor ATA 100 60 Gb disk as master on primary IDE in a homebuilt box with a Gigabyte 7ADX MB. I installed an ATA 100 IBM 40 Gb as a slave on the same IDE controller. On boot up, BIOS recognizes the new disk as a slave with SMART enabled. So far, so good. The problem starts when I try to partition the IBM disk (FAT32 logical drive). I have used both Partition Magic 6.0 and IBM's Disk Manager 2000 and got the same result. When I reboot after the partitioning operation the system takes about 15 mins to boot to Windows (98SE), with the HD light lit for most of that time. Once in Windows "most" applications run OK but sluggishly and the HD light is permanently on (but it doesn't sound like there's much disk activity). However, if I try to open Windows Exploer the systen crashes with a BSOD. I ran IBM's disk fitness test and it passed with no errors reported. If I boot to DOS the new partitions are there on the IBM disk and I can transfer files to and from the partitions - but no way can I access them from Windows. Trying to save a file to the IBM disk in Windows also leads to a crash.

I have a CD-R as master and a CD-RW as slave on the secondary IDE and notice that the eject button on the CD-R takes about 3-4 min to respond (the CD-RW responds immediately). I have AMD's IDE Bus Master driver installed so I have no DMA check box in Device Manager (probably not relevant).

If I delete the partition on the IBM disk using PM 6.0 and reboot everything is OK again - but I have no 2nd disk. I'm pretty much stumped at this point as IBM Tech Support hasn't responded. Any takers for this one?

Exile.

PS. I have another box with a Master and Slave HDD on primary IDE and Master and Slave CD-R/RW on secondary IDE with no problems.

<<<Its not what you've done with your life that matters - its what you're going to do>>>

<P ID="edit"><FONT SIZE=-1><EM>Edited by exile on 05/22/02 02:26 PM.</EM></FONT></P>
May 22, 2002 10:08:13 PM

This may be a lengthy test, but try installing the problematic hard drive as a primary drive with nothing else. Put an os on it and see how it runs. I have had simmilar problems in the past with crashed hard drives. Also, check for new motherboard drivers, specifically, Bus Master drivers rather than using AMD's driver. Are both drives made by maxtor? Are they both ATA100. Try slowing down to ATA 66 or 33 and see what happens. But before you do all of that try an IDE cable that you know for sure works perfectly.

<font color=blue>- Studies show that the human brain approaches 100 percent retention. -</font color=blue>
!