Sign in with
Sign up | Sign in
Your question

Gaming FPS problem

Last response: in Networking
Share
June 7, 2012 2:29:02 AM

Hello,
I set up my PC to be able to play games. I have a 570GTX card, quad core processor with 4 gigs of RAM, all that seems to be okay, because when I play BF3 on Ultra settings, the campaign mode gets decent framerates. The problem is when I play BF3 or even diablo 3 online, my framerates live in a low zone, then stutter down to 2 frames/second. The BIOS on my mobo and the driver for my ethernet port are all up to date. I have tried taking down my firewall and disabling my anti-virus, and I have a FIoS connection which seems to DL alright. Any suggestions? Thanks!

More about : gaming fps problem

June 11, 2012 4:52:03 AM

since u say that Single Player(offline) work fine. u only have problem while playing online..
so your computer is not at fault.
FPS drops may be caused due to high latency, what us your Internet upload and download bandwidth?
m
0
l
June 11, 2012 8:01:02 AM

From the sounds of it your single player experience is fine so the hardware itself is not the cause. The lag you are experiencing is latency lag I assume.

Run a speed test and post what your latency is: http://www.speedtest.net/.

You want the latency to ideally be under 50ms for decent gaming. I generally find anything over 140 to be a bit laggy. 200-300+ is unplayable for an FPS game. If the ping latency is fine then it may be another issue we need to look into.

Just for a bit of a laugh, I once had 20,000ms latency in World of Warcraft, each keystroke would take 20 seconds to respond. Now that's what you call bad lag :D 
m
0
l
Related resources
June 12, 2012 4:10:31 AM

Thanks for your responses, guys.
So, my ping is 12ms and my speeds are 42.75/31.49 Mb/s (down/up)
I should have also mentioned that because my PC hasn't been doing its job, I've been using my laptop on the same connection with success. Weird, huh?
m
0
l
June 12, 2012 5:16:59 AM

riggedNready said:
Thanks for your responses, guys.
So, my ping is 12ms and my speeds are 42.75/31.49 Mb/s (down/up)
I should have also mentioned that because my PC hasn't been doing its job, I've been using my laptop on the same connection with success. Weird, huh?

Your internet speed and ping is absolutely fine.
Your game performance is fine on single player.
That should equal smooth online gaming.

This is quite an odd case. Since your laptop works fine on the link, with games too i presume? That means the router is fine.

From what I can see it might be a problem on your PC that is limiting the speed, I thought firewall or antivirus but you said you disabled them.

When you play are you sure no one is downloading?

Also, when you download and surf the net do you find it to be fast? It's just games that are effected?

m
0
l
June 12, 2012 8:02:56 AM

Yup, laptop works with all the games I'm trying to play. I'm sure nobody is downloading, and the PC seems to surf the net just fine. I'm going to try upgrading to Windows 7 (I'm on Vista now), and see if that helps, but I doubt it will.
m
0
l
June 16, 2012 5:54:42 AM

hi, i came upon this while trying to search for my problems!
First of all are you using wireless or ethernet????
ok can you tell which motherboard, processor and psu u have?? I am asking because i too have same problems may be we can co relate?
secondly check ur ping after u launch a game . Because i too have a ping of about 20ms but as soon as i enter mw2 online in server it shows my ping to be above 800 and thats y i cant join many servers and if able to join i get serious lag!!
i have D-link DWA 525 pci wireless adapter and ASUS N 13 USB wireless adapter i tried both , but to avail!!!
m
0
l
!