Sign in with
Sign up | Sign in
Your question

DPC latency peaks and network connection losses

Last response: in Networking
Share
June 9, 2012 11:13:12 AM

Hi,

I have a rather serious problem which I'm trying to deal with for about 2 weeks now.

I've got a new PC which is now about 4-5 weeks old. Here's the details about components and software:


It worked great in the first 2-3 weeks, but then the network connection started to be unstable. That means that the connection is lost regularly (in intervals between 15 seconds an several minutes). After it is lost there's an immediate reconnection attempt, which usually is successful. So the connection downtime is mostly inbetween 2-10 seconds. Now that does bother me pretty badly. Especially in online games this leads to many disconnects or lagspikes of up to 10 seconds.

The connection losses always come paired with DPC latency spikes (see here). To explain it further, I've uploaded two screenshots:

This is my - unfortunately normal - DPC latency behaviour:


And this happens at every peak (look at the network connection at the top of the screenshot):


I also have another PC, which is connected to the same router (both via cable, no wifi). That one does not have these problems.

I switched the LAN cable just to be sure. I updated all drivers (including BIOS). I deactivated all eligible components in the device manager one by one. Nothing helped. The only thing I found out: If I disable the network adapter, the latency spikes are gone. But that doesn't help because the connection is gone too. For that network adapter I tried different drivers, various versions from Shuttle and also the latest original driver by Realtek. Again, nothing helped.

At this point I'm clueless. So please help me. What can I do further?

Thanks in advance,
Luzzifus.
June 9, 2012 6:04:09 PM

Unfortunately both didn't help.

Also the problem even occurs in safe mode with network drivers. Moreover this, I tried fiddling with NIC settings, energy options and a static IP address. Still no success.

I'm starting to seriously consider a hardware failure..

Quote:
viel Glueck

Danke. ;) 
!