Solved

Local area conection doesnt havea valid ip configuration?

Spent hours trying to fix this now and about ready to bang my head through the wall :(.

I currently am not getting any internet to my windows 7 pc over a wired connection, while all other computers have no issues.
Okay so here is the error I am getting: local area conection doesnt havea valid ip configuration.

I have tried power cycling my modem. I have tried releasing and renewing. When I tried releasing it wouldn't release the ipv4 and it remained as a 169.254.45.203 number (I want it to go back to the 196. number). So It can't release the ipv4. I have no idea what to do at this point. I contacted my isp and they told my I have to troubleshoot the hardware. Any suggestions? Any input at this point would be greatly appreciated. Thanks.
20 answers Last reply Best Answer
More about local area conection doesnt havea valid configuration
  1. Anyone??? Has anyone ever had this problem?

    Edit1: Okay here is an update I manually changed my ipv4 by doing this:
    http://www.howtogeek.com/howto/19249/how-to-assign-a-static-ip-address-in-xp-vista-or-windows-7/

    When I run ipconfig it confirms that my ipv4 did change to the desired ipv4, but the internet still does not work.

    But now there are two errors, the one posted above and the following: DHCP is not enabled for "Local area connection".

    Any thoughts? I am open to just about anything at this point

    Edit2: Okay so I tried releasing and renewing the ip again and this essentially got rid of the Ip I manually set and replaced it with the the 169.254. Not exactly sure what is going on here. Is there any possible way to fix this? So frustrating ! :fou:
  2. are there any lights on the network port on your computer?

    have you tried another network cable?
  3. The 169 address is what your computer is setting for you because it is unable to find a device that is handing out IP Addresses AKA a DHCP Server. In this instance the DHCP Server is built in to your router.

    In order for you to set your IP Manually you would also need to set your subnet mask, default gateway and DNS Server

    an example would be:

    IP address: 192.168.1.10 (your pc ip)
    Subnet:255.255.255.0
    Gateway: 192.168.1.1 (router ip)
    DNS: 192.168.1.1 (router ip or use googles or Open DNS's server addresses)

    The reason you can't release the configuration when its on the 169 number is because it will simply set it to the same address as it is not seeing the DHCP Server or is having problems connecting to it.

    As Emerald rightly points out above the first thing to check is that the router and PC both show the lights that indicate that the Cable is connected. So if you have your PC plugged in to Port 2 on the router for example then the corresponding light on the router should be lit up (usually green if all is well). The same will go for the lights on the PC where the cable plugs in these should be lit / flashing also.

    You really need to change the cable to ensure that this is not the issue with one that is Known Good. There are two types of cable Cross Over and Straight-Through (aka Patch lead). It is likely you will simply need a Straight-through one. This can be checked by ensuring you have the exact same cable colour sequence on both ends of the lead in the plastic connector.

    Don't worry to much about the type of cable however as most modern equipment can recognise the cable and adapt but if you have a straight one it just eliminates this as a problem. If the new cable works on another wired PC it will likely work on this one.

    If you know the cable to be good. Set a Manual IP as above and then go to Start and type cmd in the box. then type:

    Ping followed by your router address i.e. ping 192.168.1.1

    if you get replies try: ping google.com

    lets us know the results of these initial steps.
  4. jamesmcuk said:
    The 169 address is what your computer is setting for you because it is unable to find a device that is handing out IP Addresses AKA a DHCP Server. In this instance the DHCP Server is built in to your router.

    In order for you to set your IP Manually you would also need to set your subnet mask, default gateway and DNS Server

    an example would be:

    IP address: 192.168.1.10 (your pc ip)
    Subnet:255.255.255.0
    Gateway: 192.168.1.1 (router ip)
    DNS: 192.168.1.1 (router ip or use googles or Open DNS's server addresses)

    The reason you can't release the configuration when its on the 169 number is because it will simply set it to the same address as it is not seeing the DHCP Server or is having problems connecting to it.

    As Emerald rightly points out above the first thing to check is that the router and PC both show the lights that indicate that the Cable is connected. So if you have your PC plugged in to Port 2 on the router for example then the corresponding light on the router should be lit up (usually green if all is well). The same will go for the lights on the PC where the cable plugs in these should be lit / flashing also.

    You really need to change the cable to ensure that this is not the issue with one that is Known Good. There are two types of cable Cross Over and Straight-Through (aka Patch lead). It is likely you will simply need a Straight-through one. This can be checked by ensuring you have the exact same cable colour sequence on both ends of the lead in the plastic connector.

    Don't worry to much about the type of cable however as most modern equipment can recognise the cable and adapt but if you have a straight one it just eliminates this as a problem. If the new cable works on another wired PC it will likely work on this one.

    If you know the cable to be good. Set a Manual IP as above and then go to Start and type cmd in the box. then type:

    Ping followed by your router address i.e. ping 192.168.1.1

    if you get replies try: ping google.com

    lets us know the results of these initial steps.


    Okay so I am pretty sure the cable is fine becuase I run the same cable from my router to my xbox as well as my pc and my xbox still can go online (I have a splitter in my room). I manually changed everything as you said above to

    IP address: 192.168.1.10 (your pc ip)
    Subnet:255.255.255.0
    Gateway: 192.168.1.1 (router ip)
    preferred DNS server: 192.168.1.1 (router ip or use googles or Open DNS's server addresses)
    Alternate DNS server? (didnt know what to put here)

    I then tried pinging the number and it said Ping: transmit failed. General failure.

    Any other suggestions?

    Edit: to confirm the cable was not the problem I tested it on my laptop through the same setup and disabled my wireless. It worked fine so I don' think the cable is the problem.
  5. Yeah I agree sounds like the cable is good. Ok well you say you entered the details above. They were just examples. What you need to do is:

    Reconnect laptop and test as you have already without wireless on.
    then type CMD in the start menu box and hit enter
    then type IPconfig /all


    this will list the adapters and address allocated to them

    Look for the Adapter called Ethernet Adapter Local Area Connection

    Note down the various bits like IP address, Gateway and DNS Server

    Now replace those values with my example and input them in to the PC and repeat the test. I would use an IP address for the PC thought at least 10 up from whaty the laptop gets allocated.

    So where you see IPv4 Address: "Some Numbers Here" add 10 to the last number in the sequence

    Also check that your MAC address for this connection is not blank or weird
  6. Data from laptop: Ethernet adapter Local Area Connection:

    Link-local IPv6 Address . . . . . : fe80::30ef:b970:f8c6:29b9%11(Preferred)
    IPv4 Address. . . . . . . . . . . : 192.168.1.106(Preferred)
    Subnet Mask . . . . . . . . . . . : 255.255.255.0

    Default Gateway . . . . . . . . . : 192.168.1.1


    DNS Servers . . . . . . . . . . . : 192.168.1.1
    75.75.75.75
    75.75.76.76

    so on my pc when changing the static ip I used the ipv4 of 192.168.1.116(ten up from the above). changed subnet mask to 255.255.255.0. Changed default gateway to192.168.1.1. And finally changed the prefferred dns to 75.75.75.75 and the alternate to 75.75.76.76. Then I checked validate upon exit and and closed out of the properties. It gave me a warning and asked if I really wanted to do this: Warning- the default gateway is not on the same network segment (subnet) that is defined by the ip adress and subnet mask. Do you really want to save this configuration? I said yes. It then ran some stuff and said windows cand detect the correct network settings sfor you. I clicked apply this fix. My internet still does not work. The only thing I didn't do is check the mac adress. How would I go about doing this? Thanks.

    edit: my physical address (mac adress) on my desktop without internet appears to be 00-00-00-00-00-00.

    It also seems that the autoconfiguration changed my ipv4 back to a 169.254 number again :(
  7. check that you didn't mistype the ip address of the Gateway or the IPv4 address of your PC - you shouldn't get that error you got.

    Correct it and try again

    if no joy try DNS Server as 192.168.1.1 and try again

    MAC Address will be listed when you performed the actions necessary to get the details you listed above off the Laptop
  8. If none of the above works you could try this as a last ditch effort:

    Go to start type CMD in the search (DO NOT PRESS ENTER)

    Right click on the cmd icon and select "Run as Administrator" from the menu

    Then issue the following command to completely reset most of the bits that let you get online.

    ipconfig /flushdns
    ipconfig /registerdns
    netsh winsock reset
    netsh int ip reset reset.log
  9. jamesmcuk said:
    If none of the above works you could try this as a last ditch effort:

    Go to start type CMD in the search (DO NOT PRESS ENTER)

    Right click on the cmd icon and select "Run as Administrator" from the menu

    Then issue the following command to completely reset most of the bits that let you get online.

    ipconfig /flushdns
    ipconfig /registerdns
    netsh winsock reset
    netsh int ip reset reset.log

    okay I am trying it again. I will post back in a minute. I dont know if you saw my edit above,but the mac adress on my PC is all 0s.
  10. Best answer
    algar32 said:
    okay I am trying it again. I will post back in a minute. I dont know if you saw my edit above,but the mac adress on my PC is all 0s.



    Well if the above works great if not check this:

    Control Panel \ Network and Internet \ Network Connections

    Right click the Local Ethernet Adapter

    Click Properties

    Clcik the Configure button

    Click the Advanced Tab

    Find Network Address in the list and click it.

    Look at the Value in the box to the right.

    If its blank or all zeros try whacking it this value 00-0C-FF-00-3C-00
  11. jamesmcuk said:
    check that you didn't mistype the ip address of the Gateway or the IPv4 address of your PC - you shouldn't get that error you got.

    Correct it and try again

    if no joy try DNS Server as 192.168.1.1 and try again

    MAC Address will be listed when you performed the actions necessary to get the details you listed above off the Laptop

    I tried doing it again and did not get the same Warning. This time it just ran through the usual DHCP is not neable for lan
    and local area connection doesnt have a valid ip configuration.

    When I try to ping the 192.168.1.1 it says pinging 192.168.1.1 with 32 bytes of data:
    request timed out
    request timed out
    ....


    I am going to try again and set the DNS server to 192.168.1.1. Will edit back with results in a minute.
  12. jamesmcuk said:
    Well if the above works great if not check this:

    Control Panel \ Network and Internet \ Network Connections

    Right click the Local Ethernet Adapter

    Click Properties

    Clcik the Configure button

    Click the Advanced Tab

    Find Network Address in the list and click it.

    Look at the Value in the box to the right.

    If its blank or all zeros try whacking it this value 00-0C-FF-00-3C-00

    You sir are my hero. Changed the network address and it works now. Thanks for all of your help!

    Just out of curiosity, what could have caused me to randomly have my Mac wiped to 0s?
  13. No idea it happened to me also I have never found a reason or even a similar thread. I just had to mess around with my settings for a day or so before I saw my MAC address was blank and I just thought that must be it. It was and I was happy :-)

    Thing you need to be aware of is that it will have to be done again if you reinstall or restore windows as it will go blank again. From experience lol

    Glad its sorted mate and thanks for letting me know we got there.

    cheers

    James
  14. Best answer selected by algar32.
  15. jamesmcuk said:
    algar32 said:
    okay I am trying it again. I will post back in a minute. I dont know if you saw my edit above,but the mac adress on my PC is all 0s.



    Well if the above works great if not check this:

    Control Panel \ Network and Internet \ Network Connections

    Right click the Local Ethernet Adapter

    Click Properties

    Clcik the Configure button

    Click the Advanced Tab

    Find Network Address in the list and click it.

    Look at the Value in the box to the right.

    If its blank or all zeros try whacking it this value 00-0C-FF-00-3C-00


    I made an account just to thank you.

    I was about to go nuts because I kept thinking that tunngle's adapter had something to do with my IPv4 being all different from what it should be and then I used your solution -- bam problem solved.
  16. dudeicantconnect said:
    jamesmcuk said:
    algar32 said:
    okay I am trying it again. I will post back in a minute. I dont know if you saw my edit above,but the mac adress on my PC is all 0s.



    Well if the above works great if not check this:

    Control Panel \ Network and Internet \ Network Connections

    Right click the Local Ethernet Adapter

    Click Properties

    Clcik the Configure button

    Click the Advanced Tab

    Find Network Address in the list and click it.

    Look at the Value in the box to the right.

    If its blank or all zeros try whacking it this value 00-0C-FF-00-3C-00


    I made an account just to thank you.

    I was about to go nuts because I kept thinking that tunngle's adapter had something to do with my IPv4 being all different from what it should be and then I used your solution -- bam problem solved.


    Thanks for signing up just to post a thanks! Its appreciated and makes going to the effort of posting on these sites worthwhile. Thanks mate!
  17. jamesmcuk said:
    If none of the above works you could try this as a last ditch effort:

    Go to start type CMD in the search (DO NOT PRESS ENTER)

    Right click on the cmd icon and select "Run as Administrator" from the menu

    Then issue the following command to completely reset most of the bits that let you get online.

    ipconfig /flushdns
    ipconfig /registerdns
    netsh winsock reset
    netsh int ip reset reset.log



    Well this method surely worked for me. I am using Windows 8.1 and the problem was caused apparently by Cyberghost I guess....
  18. jamesmcuk said:
    dudeicantconnect said:
    jamesmcuk said:
    algar32 said:
    okay I am trying it again. I will post back in a minute. I dont know if you saw my edit above,but the mac adress on my PC is all 0s.



    Well if the above works great if not check this:

    Control Panel \ Network and Internet \ Network Connections

    Right click the Local Ethernet Adapter

    Click Properties

    Clcik the Configure button

    Click the Advanced Tab

    Find Network Address in the list and click it.

    Look at the Value in the box to the right.

    If its blank or all zeros try whacking it this value 00-0C-FF-00-3C-00


    I made an account just to thank you.

    I was about to go nuts because I kept thinking that tunngle's adapter had something to do with my IPv4 being all different from what it should be and then I used your solution -- bam problem solved.


    Thanks for signing up just to post a thanks! Its appreciated and makes going to the effort of posting on these sites worthwhile. Thanks mate!


    Men exactly the same, I just signing up to thank you, long time trying to find the problem, 3 computer: 1 working other two not, changing everything, ips, configurations, I was given up, last try before going to sleep and I found this post. Again I hope you received these thanks.
  19. Thanks for the thanks :) If you have 2 computers doing this and they are on the same network make sure you dont set them both to the same address I wrote. They all need different MAC addresses and thats just one I made up so you can use that one and make another up otherwise you may get problems with DHCP on the router.
  20. jamesmcuk said:
    Thanks for the thanks :) If you have 2 computers doing this and they are on the same network make sure you dont set them both to the same address I wrote. They all need different MAC addresses and thats just one I made up so you can use that one and make another up otherwise you may get problems with DHCP on the router.


    It is just one giving me problems, is a MSI Laptop CX6L is really weird, it is always loosing the MAC. Last time, I have to rewrite the MAC and work again.
Ask a new question

Read More

Configuration Networking