Sign in with
Sign up | Sign in
Your question

New computer built, internet speeds dramatically slower?

Last response: in Networking
Share
June 14, 2012 2:08:00 PM

Hi everyone.
I recently built my father a new computer for his office, and having done some research we've noticed that the internet speed is not what it used to be. Our ISP isn't fantastic, so before we were averaging around 7-8 mbps download and around 1 mbps upload. Now, on the new computer, we are getting 1mbps download and somewhere around .1mbps upload. These speeds are awful but running the computers side by side we see this is the case. Both were using Ethernet cables, no wireless adapters. The only thing I can think it would be is the motherboard, or some random program that is slowing this down. The motherboard is an ASRock 970 Extreme 3 if that helps. What can i do to test whether it is the motherboard, or are there any quick fixes? I have installed all the drivers pertinent to the LAN Card, and the utility to no avail.

Any help would be appreciated.

Thanks,
Kyle
June 14, 2012 3:28:11 PM

Did you try eliminating the router as a problem by switching the router ports the two pc's are connected to? Also, are the two PC's using different antivirus software? If so, try disabling the A/V software and see if it makes a difference.
June 14, 2012 6:33:57 PM

+1 for above

If not the cause try.

Install another browser and test if results are the same.

Ensure you have the latest Drivers for the Network Card from the Manufacturers site.

If they are try resetting the IP Stack:

http://support.microsoft.com/kb/299357
!