Sign in with
Sign up | Sign in
Your question

Limited connection after hibernation

Last response: in Wireless Networking
Share
May 25, 2012 1:56:48 PM

Hi this one is my first message and i hope that someone can help me :-)
i have a problem with a wireless connection on my laptop.
After pc's hibernation is impossible for me connection to internet because i have limited or no connectivity. I need reboot the pc to make it work.

i have tried to do a IPCONFIG and saw that at the pc has been assigned an IP like 169.254.x.y

Iknow thet this range is used when the server DHCP no answer, but i don't understand why it happens.
i hope that someone can help me :-)

P.S: sorry for my English, i am a italian student and don't speak english very well
May 25, 2012 4:18:41 PM

Check your power options to make sure your network card still receives power while in hibernation mode. You can also check under network adapters in your device manage to see if your network card has a power saving mode, if so make sure it is unchecked.
May 27, 2012 5:12:49 PM

johnsonma said:
Check your power options to make sure your network card still receives power while in hibernation mode. You can also check under network adapters in your device manage to see if your network card has a power saving mode, if so make sure it is unchecked.



thanks for the help!! can you help me to identify which parameters it is need to check?where i can control it?
Related resources
May 29, 2012 12:26:35 AM

What operating system are you using? Windows 7?
May 29, 2012 7:54:09 AM

johnsonma said:
What operating system are you using? Windows 7?


Yes I am using a win 7 64 bit and the latop is a dell studio 1558 with mini card WLAN wireless Dell 1397
May 29, 2012 5:06:29 PM

Adapter Settings = Start/Windows Logo---->Control Panel---->Device Manager----->Network Adapters---->Right click WLAN Wireless Dell 1397 and go to properties. Then go to the power management tab and uncheck "Allow computer to turn this device off to save power".


Power Options = Start--->Control Panel----->Power Options----->Change Plan settings---->Change Advanced Power Settings---->Change your wireless adapter settings to maximum performance, this might cause you to lose a little bit of time on your battery life by the way. So try the first option first to see if that fixes it first before you try this. Also you can try changing your PCI Express option in the advanced settings to Off for both options.
June 1, 2012 8:27:35 AM

no improvement!! i have disabled switch-off of wireless card and i have set it in maximun power.
After i have tried to set pci-express option to disable for both options but none is changed.

The pc have not problems only if i restart it every times i change network!!!
June 1, 2012 9:14:13 AM

I have also noticed if i turn off and immediately turn on the wireless card, it use ip previous the shutdown. If this ip is no avaible because for example it is already been assigned, there is the situation described in post number one with lach connectivity.

Why the ip address search is done only at startup??
June 1, 2012 9:18:07 AM

you can force the ip address to be renewed with the command

  1. ipconfig /renew
!