Sign in with
Sign up | Sign in
Your question
Solved

A little help with ICS

Last response: in Networking
Share
June 17, 2012 6:49:12 PM

Hi everyone,

I have a desktop with no wireless adapter, and a laptop with wireless internet connection through a wireless router.

I connected the laptop and desktop through a direct LAN cable
Enabled ICS on the laptop
Set the desktop's IP address to automatic
Set Bitdefender which is installed on both systems to trust the LAN

Still, I cannot access internet from the desktop. I can access the laptop from the desktop and vice versa through Windows explorer.

Both systems have Windows XP SP2.

Any help please?

More about : ics

a b D Laptop
June 17, 2012 6:53:49 PM



On the desktop, run the Network Setup Wizard in Control Panel and blob the radio button that "this computer connects though another computer" and don't bother to create a network setup CD. Restart and try the system again.

I can't help feeling things would work better under SP3 and the 130 some subsequent updates.


m
0
l
June 17, 2012 10:42:55 PM

graphicsgriffin said:
Hi everyone,

I have a desktop with no wireless adapter, and a laptop with wireless internet connection through a wireless router.

I connected the laptop and desktop through a direct LAN cable

>Ooops.. a "Direct" cable from one machine to the other?? This is possible today with machines that support auto-configure (not to be confused with auto-speed negotiating). If your computers don't suport auto-config, then try a crossover cable between the machines and establish the ICS link before enabling the wireless for the internet.

Enabled ICS on the laptop
Set the desktop's IP address to automatic
Set Bitdefender which is installed on both systems to trust the LAN

Still, I cannot access internet from the desktop. I can access the laptop from the desktop and vice versa through Windows explorer.

Both systems have Windows XP SP2.

Any help please?

m
0
l
Related resources

Best solution

a b D Laptop
June 18, 2012 6:40:50 AM

You don't need ICS to accomplish this task. ICS is both a bridge and a router (that's why it has its own DHCP server and creates its own network (192.168.0.x)). But you already have a router! So ICS is overkill. You only need a bridge. Go to Network Connections (Start->Run, type "ncpa.cpl" (no quotes), and hit enter), select the two connections, right click, and select Bridge Connections. That's it. Now the desktop can sends its DHCP request over the bridge to the wireless router like every other device.
Share
June 18, 2012 5:37:14 PM

@ Saga Lout, I already tried that. Thanks anyway

@ tigsounds, I am actually now using an Ethernet switch, after the direct cable failed in the first try. Thanks anyway

@ eibgrad, I have just tried this now, it's just not working. Should I change the IP settings of the bridge or leave it as automatic? Both ways it's not working. The two systems can connect to each other, and the laptop can connect to the wireless internet router, but still the desktop cannot connect to internet. I also tried to set Bitdefender on both systems to trust the network and allow all systems.

What about ip settings, for desktop, laptop, and bridge, static or automatic?
m
0
l
June 18, 2012 5:46:19 PM

It's working now! I changed all ips to automatic. I will see if it the connection stays alive for some time. Thanks a lot.
m
0
l
a b D Laptop
June 18, 2012 6:38:36 PM

graphicsgriffin said:
It's working now! I changed all ips to automatic. I will see if it the connection stays alive for some time. Thanks a lot.


What's working? ICS? Bridged connections?
m
0
l
June 18, 2012 7:12:22 PM

eibgrad said:
What's working? ICS? Bridged connections?


The bridge. It is working, for now. I will see if it will still work tomorrow.

Thanks a lot for your help. ;) 
m
0
l
June 21, 2012 1:29:28 PM

Best answer selected by graphicsgriffin.
m
0
l
June 21, 2012 1:29:34 PM

Good news. It's still working. Thanks again.
m
0
l
!