Sign in with
Sign up | Sign in
Your question

Very annoying internet connection problem

Last response: in Wireless Networking
Share
May 29, 2012 4:26:33 PM

OK so here goes..

I set up a brand new Windows 7 Home Professional system around 6 months ago, and ever since, the internet connection speed, specifically the download speed, has been very changeable, going from occasionally quick, to medium, and occasionally very very poor to the point that it is un-usable.

My home network is a set up with a G Router, and prior to changing from XP to 7, my connection was a solid 11.5M download speed, as it remains on my laptop connected wirelessly (Vista) which is a constant 11.5M download speed, and also using speed-test on my iPhone, which registers the same speed, as such the connection is not the issue here, i'm sure that it is either related to my adapter, or windows 7 settings.

I have posted links to various speed-tests results which i have carried out to see the issue. I have tried the following to no avail:

- Flush DNS and similar command prompts
- Disabling IPv6 in network connections
- Disabling QoS in network connections
- Full re-install with format of Windows 7
- Booting in safe-mode
- Disabling various start-up services in msconfig

I am relatively computer 'savvy' and i am at my wits end after thinking that i had solved the issue tonight, by re-installing the driver for the adapter (A Belkin N v6 adapter) with a downloaded driver, and then going into the driver options via network connections, and updating driver>have disk, and selecting the driver file manually from the disk which came with the adapter. After i had done this, hey presto - everything was rosy for the first time on this set up, and my connection was a permanant 11.5m download speed on speedtest.

This stayed the same for around two hours, and a bit of surfing later, i'm back to square one with the latest of the speed test results.

Please help!

Many thanks for reading.

Nick






Latest:



Uploaded with ImageShack.us
May 29, 2012 7:51:14 PM

Thank you - that does seem to have worked for now at least!
!