Sign in with
Sign up | Sign in
Your question

Slow internet with Linksys E2500

Last response: in Networking
Share
June 24, 2012 1:33:21 PM

Good morning,
I have have tried days of online researching and even calling Linksys (CISCO) about the problem I am about to describe.

When I am connected directly to my modem I am able to get around 24 Mbps. Now when I connect to my Linksys E2500 I am only able to get around 10 Mbps. I am really confused by this and I have not seen a solution anywhere for this.

If anyone is able to help me out, I would greatly appreciate it.

Thank You.
June 24, 2012 3:16:08 PM

Only getting 10Mbps when using wired or wireless?
m
0
l
Related resources
June 24, 2012 5:44:07 PM

I'm not familiar w/ this particular router, but here are some suggestions.

1. Make sure you're using the latest router firmware. Bugs do happen and it's best to have the latest firmware when things aren’t running as expected.

2. Do a factory reset. Let's start w/ a KNOWN state and thus eliminate the possibility of some errant settings you may have made.

3. If it has a QoS (Quality of Service) feature, make sure it's disabled.

4. When using either a direct connection to the modem, or using the router, use the SAME ethernet cable. You want to eliminate the possibility of a bad cable (rare, but the fewer variables, the better).

5. If possible, test the speed of the router between two wired computers on the same LAN, rather than just testing the internet connection. Let’s see if the problem affects the router generally (i.e., local or internet traffic), or ONLY affects the Internet side of the router. Something like NetCPS and/or Iperf would be good tools for this purpose.

6. While you’re at it, disable the wireless radio(s) too. And if the router supports USB, don’t connect anything to it, no printers, no external storage, nothing. It’s not obvious to me how this could affect the wired connection, but again, the fewer variables, the better. Let’s keep the configuration super simple.

Basically you have to go through a process of elimination so the number of possible culprits becomes manageable. The less things going on within the router, the better. Otherwise you’re just throwing darts at the problem.
m
0
l
July 21, 2012 2:33:44 PM

Disabling QOS fixed it for me!

thank you
m
0
l
Anonymous
July 14, 2013 1:37:25 PM

I was having the same issue. Wireless speed was only 25Mbps. After disabling WMM Support in QoS settings my speed jumped up to 78Mbps!

Thanks!
m
0
l
!