Sign in with
Sign up | Sign in
Your question

[NOT SOLVED] TightVNC extremely slow on only 1 PC (LAN)

Last response: in Networking
Share
June 29, 2012 5:29:03 PM

:bounce:  WAZZAAAAAAA

Okay, so I'm looking for a solution for that god damn problem. Here, we've got TightVNC as remote desktop connection. We use it on our LAN network so people can help others when they have troubles.

Blablabla...

Anyway, we've got only 1 PC that run tightVNC TOO SLOW ( too slow so it's useless ). The PC run windows 7 64-bits. The fact is that it's not the only one win7 64-bits and all the others ( I said ALL ) works perfectly. I did speed test lan because, at first, I thought it was a network problem, but NO, the connection is perfect. tightVNC configuration is the same on every PC, but THIS ONE doesn't work for no reason (apparently... ).

I looked for solution on the internet and found those that I need to check/test ;

windows update
if the client is set on high speed mode
if the tightvnc server is set on poll refresh full screen
screen resolution
if the quality of colors is set on 24-bits
speed connection setting on VNC
graphic drivers update

But, before doing this, maybe I just skipped something evident that you could see or simply that you already had that problem before and found a fix?


Right now, time is 13:27 and I can go test these solution at 16:00. After that, I'm gonna share my results to you ( and hope to find a fix... ) but if you can help, I would be happy! I'm out of idea right now.


Thanks and sorry for my bad english, I did my best.

Love you guys
a b X LAN
June 29, 2012 5:38:06 PM

If possible, can you test it in the opposite direction? IOW, make the server the client and vice versa? I just want to see if there's a difference. If there is, then that would suggest it's a VNC configuration issue. If not, it would suggest it’s a network issue.
m
0
l
June 29, 2012 5:52:33 PM

(1rst reply)Yes MISTER EIBGRAD I did test it in the opposite way. Look at the results

Desktop => remoted desktop ( Writing 785 Mbps / Reading 504 Mpbs )
Remoted desktop => Desktop ( Writing 745 Mbps / Reading 459 Mpbs )

It's very similar ( Time between each test is 15 minutes so it can be the network traffic too :/  )

(Your dog seems cool)

(2nd reply) God damn, I tried evrythin' and didn't gave me alot of result. I couldn't test it on vnc ( -.- ) and found that the screen polling was at 1000ms ( 1 sec each refresh wtf? ) and it was maybe my problem. STILL, I had the same problem on dameware and couldn't fix it, so I hope to see the result on VNC. I wouldn't be surprise that it was because of the screen polling as I wouldn't be surprise if the problem isn't fix.

Anyway, we'll see it tuesday ( monday break, happy birthday canada ). Peace out

(3rd reply) Okay so i'll continue to write here in case that someone could fell on that post by google if he has the same problem. And, to finish my last post, it wasn't the screen polling option.

so here's what left for solution. In the case any of this work, I'm pretty wtf. ( I checked everything that could cause the problem no? xP )

1- So I discovered that the version of tightvnc wasn't the same on the computer who has the problem. In like an hour, I'll install a up-to-date version.

2- I discovered that the computer who has the problem doesn't have any mirror driver ( as evryone has one ). In all the other PC, they do have, at least, dameware development mirror driver. I don't know if tightvnc use this, but anyway, they do have their proprietary mirror driver. I'll try with the dameware first, then install the tightvnc too just to be sure. And anyway, it suppose to add more fluidity if I add the mirror driver, maybe enough to make the computer useful in remote session.

gonna update the post by 5 pm ( right now it's 3 pm over here ).
m
0
l
Related resources
July 6, 2012 8:10:02 PM

Okay, I succeed to make the pc usefull when in tightVNC.

Here's a brief of what happenned.

Someone were having problem while using tightvnc on ONE UNIQUE PC. The PC was on a LAN connection.
The desktop who has problem ( the remoted one ) was a Windows 7 x64. He wasn't the only one and all the other computer running in tightvnc ( they could be winxp, win 7 x86, x64 ) were all running great, there's even some of them who has dual-screen. So it wasn't a resolution problem ( often the computers who are slow in VNC has 24bits color depth ) and it wasn't a aero / compatibility problem. Because the problem were only on one computer, I did a speed lan test. The test showed good result so it isn't a network problem. I soon did the update of the faulty computer, checked the graphic drivers, checked the VNC configuration ( set on high speed, 8-bit mode, hexel compression, screen polling set on 100ms, right PORT... ). EVERYTHING WAS OKAY and the problem wasn't fixed. I looked in the computer looking for a difference, and I FOUND ONE.

SOLUTION:
ALL the computer on the network are equiped with a Dameware development mirror driver. This driver helps optimize the performance if the computer is remoted and seems to cohabit with tightvnc. As I don't want to take any chance, I decided to install the tightvnc mirror driver (avaible on their website). AND IT SOLVED MY PROBLEM.
( I DID UPDATE MY NETWORK CARD DRIVER )
Maybe it wasn't the cause, still, the gain it gives is enough to use the computer on tightvnc. W000T. Anyway, I hope to help someone with this post.

Peace out.

It was a very stupid problem ( why I haven't thought about this before... ) But, as always, the more complicate is the problem, the more stupid is the solution.


m
0
l
July 11, 2012 8:42:47 PM

Well it seems that the problem IS NOT SOLVED...
m
0
l
!