Sign in with
Sign up | Sign in
Your question

Windows 7 - Asrock motherboard

Last response: in Windows 7
Share
February 7, 2010 9:37:45 AM

I have a Asrock K8NF4G-SATA 2 motherboard and have tried to install Windows 7. Whilst this motherboard does not appear in the list of compatible motherboards (http://www.asrock.com/news/events/2009win7/index.asp), its spec in terms of RAM, processor and graphics card suggest the 32 bit version of Windows 7 should work fine.

After many attempts, I finally got Windows 7 installed, noting that I had to disable onboard SATA and onboard audio in the BIOS to get it to install (not a major problem though I could clearly do with sound at some stage). However, once installed none of the USB sockets (4 on the back or 2 on the front) work at all and there is an exclamation mark next to one of the USB devices on the device manager screen. Tried to connect to the internet (hoping that Windows 7 would then automatically update all the drivers/devices) using a LAN cable from my wireless router (as I always had done under XP) but no internet connection was made, so basically the LAN socket was also not working.

Tried borrowing a friends PCI LAN adaptor, but no luck. Same story with a PCI USB adaptor, still the USB would not work. I have a PCI wireless adaptor with Windows 7 drivers (on CD), this seemed to install no problem but it doesn’t find any wireless networks, noting that there definitely is one in my house as wireless netbook works fine.

The Asrock website mentions in the FAQs that if your motherboard is not listed to “try inbox driver”, what does this mean? If it means the CD that came with the motherboard, the stuff on this is not Windows 7 compatible. The FAQs also suggest trying to download chipset drivers from the following list:

Intel website: http://downloadcenter.intel.com/Default.aspx
AMD website: http://support.amd.com/us/gpudownload/Pages/index.aspx
Nvidia website: http://www.nvidia.com/Download/index.aspx?lang=en-us
Realtek website: http://www.realtek.com.tw/downloads/
Via website: http://www.via.com.tw/en/support/drivers.jsp

Which ones would be relevant for my motherboard? Downloading will not be straightforward without USBs or internet, but could do it via CD (the CD drive works!) if there was a good chance of it working.

On the other hand, if really my motherboard is too old and can’t be made to work with Windows 7 please let me know so I don’t waste any more time playing around.

I would appreciate a quick reply, many thanks.

Chris
February 7, 2010 11:59:22 AM

It ids not too old, I had W7 running on old Pentium 3 running without problems, all drivers installed just fine. USB should definately work without additional drivers. You either have bad installation CD or hardware fault.
m
0
l
!