Sign-in / Sign-up
Your question

LAN/Ethernet not working

Tags:
  • Ethernet Card
  • Networking
Last response: in Networking
June 30, 2012 6:22:30 PM

hi

i had to reinstall windows 7 so i decided to get a ssd and install it on that. i installed and began to install motherboard drivers. every driver installed fine besides my Ethernet controller. i thought it was just a hiccup so did it again and i have tried many times now and it still freezes whilst installing. when i go into device manager it did somthing cause it says a driver is installed and gives the controller a name. when i right click it said code 31. so i looked into that and did what was asked and changed hardware around and still nothing. looked into upper and lower filters but the registry does not show them.

to quickly some up this is what i have attempted:
change back to original hard drive
different versions of drivers
updating bios
tried different operating system
and manually installing driver

any help is very appreciated.
oh and everything was fine before
thanks

More about : lan ethernet working

June 30, 2012 8:15:51 PM

Just to be sure the ethernet adapter is working properly, try booting a live Linux CD (e.g., Ubuntu) and see if it works.

P.S. I know you said you tried a different OS, but you weren't specific, and perhaps only tried Windows.

June 30, 2012 8:21:55 PM

i tried ubuntu but it hangs and i cant install so i used jolicloud and no sign of the adapter working.
Related resources
June 30, 2012 8:29:07 PM

Hmm, not a good sign, that suggests a hardware failure. It's pretty rare these days for an ethernet adapter to not work in any OS unless it's really some obscure make/model. Wireless adapters are a different story.

Are you sure it was really working before the reinstall? Is it possible you were using wireless up to that point and didn't notice this problem on the wired side?
June 30, 2012 8:43:04 PM

yep it was fine. been using it since September and was definitely not using wireless.
i also notice that when i connect a cable one of the two lights begin to flash yellow then stops but the orange light stays on. i also tried a different cable.
June 30, 2012 8:53:29 PM

Try completely discharging the system by pulling the power plug, turning off the power supply switch, pulling the 24-pin connector from the motherboard, and popping the CMOS battery. Let it sit for say 60 mins. Then reconnect everything and try again.
June 30, 2012 9:41:42 PM

i will try that first thing tomorrow. thanks for the help, will check back in tomorrow with update. thanks
July 1, 2012 2:45:39 PM

hi
i tried what you suggested besides popping out the CMOS but still does not work. tried only using one stick of ram, did not work. is there any thing else i can do? besides buying a pci with ethernet. i might try different BIOS version again.
July 2, 2012 9:38:40 AM

If you are on a machine with no network connection, use a floppy, USB drive, or a CD-R disk to transfer a text file with the information to allow pasting it here.then please Download and run this Xirrus Wi-Fi Inspector, click the Networks link on the upper left and paste a screen shot of that screen here. Note that this application requires NET Framework to run. If you get an error about a missing function, download and install NET Framework.