Sign in with
Sign up | Sign in
Your question
Solved

Wireless Repeater headache

Last response: in Wireless Networking
Share
June 11, 2012 12:17:13 AM

I'm a bit at my wits end regarding this issue and if anyone could help me go over what I've done wrong, I would gladly appreciate it.

This all started when I decided to set up a wireless repeater in the house I am living in. The signal to the main router (D-Link DIR-655) is super weak or even non-existent from my room. I had a spare router(Linksys WRT54GSv7) in the house and read somewhere that I could turn it into a wireless repeater using dd-wrt.

I was able to successfully connect to the main a router with this repeater and my signal isn't bad... though it does tend to lost signal and crap out every once in a while. This isn't the problem though. The problem I have is that I am not able to connect/share with other devices. Mind you, I am able to connect devices to this repeater like my wireless printer, my cellphone, etc., but I am not able to see one without the other. I am not able to print anything wirelessly because my computer doesn't see the printer as online nor can I use this network to help stream content to the PS3 that is connected to the main router downstairs.

First world problems, amiright? If anyone can give me guidance, I would appreciate it. I'll provide other details as well.

Also: Win7 Ultimate Edition, i7 processor, and wireless LAN receiver module MS-3871 (http://www.intel.com/support/motherboards/desktop/sb/CS...)
a c 80 F Wireless
June 11, 2012 5:23:40 AM

what is the LAN IP of the Linksys?

make sure it is something like 192.168.0.253 since the D-Link is usually 192.168.0.1
m
0
l
June 11, 2012 6:13:53 AM

Emerald said:
what is the LAN IP of the Linksys?

make sure it is something like 192.168.0.253 since the D-Link is usually 192.168.0.1


The LAN IP of the Linksys (the one where I can log in and change settings right?) is 192.168.2.1. I also realized that I am able to access the D-Link with it's IP: 192.168.0.1 Is that normal?
m
0
l
Related resources
a b F Wireless
June 11, 2012 8:35:12 AM

As it looks Johnny your two devices are on different Subnets, thats why they can't communicate!
You will need to change the IP of the Linksys to 192.168.0.2 for them to be able to communicate. You will also need to disable the DHCP (if it is turned on) on the Linksys.
You can find both of these settings on the Linksys configuration under LAN Settings.
Also if there is a firewall running on the Linksys turning it off will make things easier for you. The D-Link will handle the firewalling for your network!
Turn off the D-Link and set up the Linksys as I described above. When finished the setup save you settings and turn the D-Link back on and you should be fine!
Cheers!
m
0
l
June 11, 2012 9:50:15 PM

ngrego said:
As it looks Johnny your two devices are on different Subnets, thats why they can't communicate!
You will need to change the IP of the Linksys to 192.168.0.2 for them to be able to communicate. You will also need to disable the DHCP (if it is turned on) on the Linksys.
You can find both of these settings on the Linksys configuration under LAN Settings.
Also if there is a firewall running on the Linksys turning it off will make things easier for you. The D-Link will handle the firewalling for your network!
Turn off the D-Link and set up the Linksys as I described above. When finished the setup save you settings and turn the D-Link back on and you should be fine!
Cheers!


Hello ngrego,

I followed you advice and I turned off the D-Link router and changed the IP of the Linksys to 192.168.0.2, disabled the DHCP, and made sure the firewall was off.

However, now the signal appears only to have limited access. I can connect to the repeater router(Linksys) through wireless lan, but no internet. Also, when I try to log into the router using the '192.168.0.2' address, nothing shows up. Neither does '192.168.0.1' nor '192.168.2.1'.

Should I try to reset the linksys repeater router?
m
0
l
June 12, 2012 1:25:43 AM

An update.


I was able to change my settings so now the Linksys repeater router has the IP '192.168.0.2' and I have internet access... however now no other devices seem to be able to connect to the repeater router. I'm sorry for being so problematic, but if anyone has any knowledge they could impart on my or know something about dd-wrt that I don't know, please contact me
m
0
l
a b F Wireless
June 13, 2012 10:12:13 AM

Have you also checked out the DHCP setup on the DLink (Gateway)? Is the DHCP turned on? If so, how is the DHCP set up?
If possible post an image..
Do any of the devices have manually issued IP addresses?
You must check the Network settings of the other connecting devices, set them to "Auto" so they can connect.
m
0
l
June 14, 2012 12:11:14 AM

ngrego said:
Have you also checked out the DHCP setup on the DLink (Gateway)? Is the DHCP turned on? If so, how is the DHCP set up?
If possible post an image..
Do any of the devices have manually issued IP addresses?
You must check the Network settings of the other connecting devices, set them to "Auto" so they can connect.


Thanks again for responding ngrego.

Here is the general info on the routers:

DLink (Main) - http://i.imgur.com/fowrf.jpg
Linksys (Repeater) - http://i.imgur.com/q3nWB.jpg

I don't know if this helps any. To reiterate, the problem deals with network connection and sharing. I've been able to tweak the Linksys so that different devices can connect to and have access to the internet. The only problem is that I am not able to communicate with devices connected to the Linksys (i.e. My wireless printer is connected to Linksys as well as my main computer, but main computer says printer is disconnected/online).

When I was connected to the main router in the past (the Dlink) directly, I was able to share content as well to other devices in the network (PS3 media server, media file sharing on other computers, etc.). Now, not at all.

Thanks again for helping this newb out.
m
0
l
a b F Wireless
June 14, 2012 7:38:07 AM

No Prob, and thanks for the screen shots.
Could you please post me a screen shot of the DHCP Setup on the Dlink and the Security Setup on the Linksys. Both screens shot were helpful and informative but I will need a bit more info.
It seems as if there is something blocking your access to the devices, but it's not too clear now.
One thing I can see is that you are on channel 10 on both. That has nothing to do with your issue but it may cause some disturbance on the connections if the routers are close together, using the auto setting is usually best!
m
0
l
June 14, 2012 3:07:25 PM

ngrego said:
No Prob, and thanks for the screen shots.
Could you please post me a screen shot of the DHCP Setup on the Dlink and the Security Setup on the Linksys. Both screens shot were helpful and informative but I will need a bit more info.
It seems as if there is something blocking your access to the devices, but it's not too clear now.
One thing I can see is that you are on channel 10 on both. That has nothing to do with your issue but it may cause some disturbance on the connections if the routers are close together, using the auto setting is usually best!


Dlink:
http://i.imgur.com/cLkqX.jpg
http://i.imgur.com/aC71a.jpg
Linksys:
http://i.imgur.com/bILo9.jpg
http://i.imgur.com/cBMSu.jpg
m
0
l
a b F Wireless
June 14, 2012 5:50:17 PM

Sounds like a classic case of having used "repeater" rather than "repeater bridge".

Repeater differs from repeater bridge in that the former creates a *new* network behind its own firewall, DHCP server, etc. In constrast, the latter (repeater bridge) is completely transparent and remains on the same network (and thus uses the same firewall and DHCP server of) the remote AP. Repeater is fine if you only expect clients behind the repeater to access resources on its own network and anything upstream, beit the remote AP’s network or the Internet. But the repeater BLOCKS access from the remote side of its firewall from that same remote AP! That’s why using repeater for say, a printer or media server, is a bad idea. You want “repeater bridge” so you have unimpeded access in both directions.
m
0
l
June 14, 2012 6:02:23 PM

eibgrad said:
Sounds like a classic case of having used "repeater" rather than "repeater bridge".

Repeater differs from repeater bridge in that the former creates a *new* network behind its own firewall, DHCP server, etc. In constrast, the latter (repeater bridge) is completely transparent and remains on the same network (and thus uses the same firewall and DHCP server of) the remote AP. Repeater is fine if you only expect clients behind the repeater to access resources on its own network and anything upstream, beit the remote AP’s network or the Internet. But the repeater BLOCKS access from the remote side of its firewall from that same remote AP! That’s why using repeater for say, a printer or media server, is a bad idea. You want “repeater bridge” so you have unimpeded access in both directions.



Unfortunately, I wish that was the reason. You can see that my Linksys is currently on the "repeater bridge" setting: http://i.imgur.com/q3nWB.jpg. It did take me a little reading to figure that out before though.

Please let me know if there are other things I should look out for. Thanks eibgrad.
m
0
l

Best solution

a b F Wireless
June 14, 2012 6:29:44 PM

Hmm, then do the following (because it's really easy to make a mistake if you've mucked w/ the individual settings, like disabling DHCP server and firewall manually). Normally it's really easy because the default configuration should take care of all these details for you.

Reset the dd-wrt router (the one acting as a repeater) to defaults. Once that's done, configure the router as "client bridge". All that requires is giving it a new static IP (192.168.0.2, to be consistent w/ your current work), save and reboot, change wireless mode to "client bridge", save and reboot, then finally add wireless security, save and reboot. That’s it, no more! (well, you could also assign the WAN to the LAN on the setup page too, but that’s optional, otherwise you need to avoid using the WAN port).

At that point you should be able to connect wired devices to the router (now a client bridge) and work in either direction. Until that's the case, don't go any farther.

Once that's working, using that same configuration, change it to "repeater bridge". Now add the new virtual interface for the repeating SSID, save and reboot, add wireless security, save it and reboot, and it should be working, only now you should also have wireless access in either direction across the bridge.

IOW, repeater bridge is just an extension of client bridge. It's client bridge + the addition of an AP to add wireless clients to what was previously only wired clients. If you take it in TWO STEPS this way, you're much less prone to errors. It also tends to make it clearer exactly what is happening. Repeater bridge becomes less of a mystery once you see it's an extension of client bridge.
Share
June 22, 2012 4:14:59 AM

Best answer selected by johnnypoozer.
m
0
l
June 22, 2012 4:16:19 AM

I just pretty much reset the repeater again, set it on repeater bridge and I was at least able to connect to my wireless printer, which is a buttload of relief. I'll figure out how to connect to devices connected to the main router another time. Thanks eibgrad and nerego.
m
0
l
November 28, 2012 12:59:39 AM

I too have a similar setup with my network as I used a Linksys E2500 as the main router. The best part is that because of the simultaneous dual band capability I can then run my other Linksys E2000 with Tomato running 5ghz band for when i switch to my home theatere.

It provides a wired ethernet to my set-top box and bluray. The other part is that I also have a Linksys WRT160N (with Tomato Toastman’s build as well) which then provides wired ethernet to my home office. In doing this it allow me to watch video at 5ghz without any interference to the data network running on 2.4ghz.

You've spent a lot of time so for trying to get things to work the way you have but I still say try Tomato if you haven't already. You can get it at http://www.polarcloud.com/tomato and there's a few people that offer some pretty standard guides over at http://www.wifirepeaterreviews.com that are pretty good.
m
0
l
!