Sign in with
Sign up | Sign in
Your question
Solved

Setting up a VPN connection to a computer behind two routers?

Last response: in Networking
Share
July 17, 2012 6:39:38 PM

Hello, and thanks for any help you are able to provide. Here is the history:

I had a VPN connection set up to use iTap RDP on my iPad to remote in to my office. It worked great. I was using a Cisco RV082 router with a PPTP connection. Then, I had to alter my office network to where there are two separate networks sharing one internet connection. Emerald was kind enough to set me straight on how to do that. So, at the office, I now have a cisco cable modem going to the cisco RV082 router and from there a cisco E2500 for network one and from the RV082 to a WRT120 for network two.

My question is what do I have to change/add to the settings in order to connect to network one through the RV082/E2500 combination? Under the iTap RDP settings, I setup the RV082 as a gateway and I get a green light for the gateway connection, but an error trying to connect to the computer. Perhaps this wasn't needed, but thought I would try that before asking for help.

Thanks again for your thoughts!

Chris
July 17, 2012 11:03:22 PM

If I understand the situation, the problem is that before you only had the RV082 router, and therefore you RDP'd directly to your desktop on that network (no need for port forwarding). Now you have split that into two different networks (so you really have three networks) and need to further direct your request from the RV082's network to that of the E2500.

Seems to me it's just a matter of adding an RDP port forward on the E2500. Of course, the E2500 will need a static IP from the RV082's network to be reliable. You’ll RDP to that static IP, and the port forward will take you to the desktop behind that router.

Btw, make sure every router is using different networks (e.g., 192.168.1.x, 192.168.2.x, 192.168.3.x), including the one you're VPN'ing from! If there's any duplication, that's a mistake which can cause big problems.
m
0
l
July 18, 2012 1:59:20 AM

You have understood the situation perfectly even with my confusing description. Thanks for including the BTW. You are correct that I originally set up the router at the office as 192.168.1.x and home as 192.168.2.x. When I added the two additional routers at the office I used 192.168.2.x and 192.168.3.x. I forgot about that. I'll make that change tomorrow and try connecting again.

Thanks for the help, I'll let you know how it turns out.

Chris
m
0
l
Related resources
July 18, 2012 9:46:53 PM

Nope, changing that didn't help me:( 

I can see under the RV082 settings that the iPad is connected to the VPN, but I guess from there I don't know how to direct the connection to the E2500. Am I supposed to make the connection some how pass through the RV082 and then connect to the E2500?

I'm still searching sites for help, but so far, haven't figured it out.

Thanks
Chris
m
0
l

Best solution

July 18, 2012 10:27:05 PM

Unless there’s more here than you’ve described, the process is pretty straight forward. Once the VPN client places you on the VPN server’s network (let’s say that’s 192.168.1.x), your only task is to find the router behind which is the remote desktop. That router must have a static IP on its WAN within that same network (let’s say that’s 192.168.1.100). That is the IP address you need to specify in your RDP request. Of course, that router will also need a port forward (3389) to the remote desktop behind it.

Is it possible for someone to verify that you can get to the remote desktop while physically *on* the 192.168.1.x network (i.e., no VPN) before attempting to use the VPN? It always helps to break down the problem and verify the individual pieces actually work, then pull them back together.
Share
July 18, 2012 10:38:04 PM

Yep, if I have my iPad connected to the office's wireless connection, I have no problems using the iTap RDP app.

The E2500 (behind the RV082) is set to static at 192.168.1.101.

I bet the problem is me specifying that as the address for the RDP request.

I am pretty sure I have the E2500 set up properly to port forward 3389 to the remote desktop.

Going back to work on suspected problem:) 

Thanks
Chris
m
0
l
July 18, 2012 10:45:46 PM

Best answer selected by cwbddspc.
m
0
l
July 18, 2012 10:45:48 PM

That was it!! Working great. I had the iTap RDP app set up to connect to my computer. Switching it to the address of the E2500 was the puzzle piece I didn't know how to do. Awesome! You da man ( woman/person/etc:)  )
m
0
l
!