Sign in with
Sign up | Sign in
Your question

Some javascript actions not working on any computer, any browser!?

Last response: in Networking
Share
July 19, 2012 8:56:57 PM

This is a weird one. I have four Dell computers (Dimension C521, Lattitude e4600, Lattitude e6520, Aurora R3) and a Macbook Air. Not a single one of them can expand the drop-downs on Dell's drivers and downloads site. I have tried with IE8 & 9, Chrome, Firefox. Because it happens on all computers, including Mac, it indicates some kind of common network issue to me. (Maybe not? I just tried the site in Safari and the javascript drop-downs all work!)

I have disabled the windows firewall with the same results.

What could possibly be causing every instance of every browser (except safari) on all computers to fail to allow javascript??
July 19, 2012 11:48:14 PM

Are you sure it's not effecting others besides yourself? Why not post the link(s) you're using, let's find out.
July 19, 2012 11:54:10 PM

Sorry - I meant to post the link. Here is just one example: http://www.dell.com/support/drivers/us/en/19/DriversHom...

On this page, it asks for a service tag, or if you don't have one to choose from an option. For me, the "submit" buttons do nothing.

I've asked others I work with to check and they are not having the problem. Dell support also stated they have no issues with navigating the site.
Related resources
July 20, 2012 12:18:56 AM

I tried a bogus number, it reports:

"We were unable to verify the Service Tag or Express Service Code you have entered. Please verify your entry or choose one of the options to the right. If you recently purchased a system, please try again in 48 hours."

So it’s certainly doing “something” here.

Is it possible you installed an add-on like NoScript or other anti-malware?

If you suspect the router (which seems highly unlikely), try connecting one of the troublesome PCs directly to the modem.
July 20, 2012 12:21:25 AM

"Is it possible you installed an add-on like NoScript or other anti-malware?"

Not likely, three of the four PCs have fresh installs of windows. Why would safari work on the macbook, but not chrome? Something else is going on .. it's been a mystery since I first bought my Alienware Aurora R3. At first, I thought only the alienware was affected. Then I realized it was every computer on my network.

Something else is afoot.
July 20, 2012 12:42:38 AM

That's why I suggested a direct connection to the modem, to remove the other common element, the router. I know, that doesn't explain the macbook/safari, but I'd probably try it just to eliminate it.
July 20, 2012 12:44:12 AM

I'll try that. Sorry, I must have overlooked you suggesting it. For the record, I've had 3 different wireless routers since the problem started.. It's highly unusual if all 3 wireless routers would be introducing this issue.. But I'll give it a shot and bypass the newest one.
July 20, 2012 2:53:54 AM

Confirmed. It still happens while connected directly to the cable modem. In fact, I called my ISP, and the gentleman I was escalated to found that it happened intermittently on his side as well between multiple browsers. I think this takes me back to my initial assessment that it is Dell's website and coding.
!