Can\'t connect wirelessly to MI424WR

I am using Windows 7 on my laptop and trying to connect to my dad's Actiontec M1424WR router wirelessly. It picks up the signal fine, but whenever I try to connect, it takes a while and then just says it can't connect. It will continue to try and connect, only ever getting as far as limited access then quickly losing the connection, all with a Good signal. My dad and brothers all use Windows 7 laptops as well and they are and have been connected just fine. We tried a wired connection and that works perfectly too, so the only problem is getting it to work wirelessly now. Any help or experience would be greatly appreciated.
1 answer Last reply
More about connect wirelessly mi424wr
  1. Is the router wireless G, N? Is the wireless adapter G, N?

    What are you using for encryption (WEP, WPA, WPA2)?

    Is this a router/laptop combination that has never worked correctly over wireless, or has worked previously and only became a problem recently?

    Are you using your laptop's built-in wireless adapter, or an add-on (e.g., USB)?

    What happens if you're right next to the wireless router, same problem?

    Try briefly disabling wireless security on the router, any change in behavior by your laptop?
Ask a new question

Read More

Routers Laptops Windows 7 Connection Networking