Sign in with
Sign up | Sign in
Your question
Solved

Unable to navigate to shared drive

Last response: in Networking
Share
July 23, 2012 1:57:58 PM

Hello,
I am on Windows 7. Up until a week or so ago, I used to be able to navigate, using Windows Explorer, ( Network > ServerName > SharedDrive) , to a particular shared network drive. I can no longer do this as I get the following message:

"\\ServerName>\<SharedFolder> is not accessible. You might not have permission to use this network resource. Contact the administrator of this server to find out if you have access permissions.
An unexpected network error occurred."

Now, if I modify the name of the server in the explorer address bar to include the fully qualified domain name, I am able to get to the shared folder. There are other folders on that same server where i CAN navigate to WITHOUT having to modify the server name.

This does not appear to be a simple permissions issue as i can get to the folder using FQDN. Also, a permissions error has a different message:
"Windows cannot access \\Walfile1\psg
You do not have permission to access \\Walfile1\psg. Contact your network administrator to request access."

This seems to me to be some sort of routing or DNS issue.

Sorry for the long winded message but my local IT is of no help, they just tell me that I have to use FQDN, - which doesn't make sense and is less than satisfactory because no one else in the organization has to, I can navigate to other folders on the same server with no problem, and in order to access links that people send me to those folders, I need to modify them.

I used navigating as an example but of course, all access to that shared drive now requires me to use FQDN, links, command line access, shortcuts etc.

Any help would be very much appreciated
July 23, 2012 3:21:54 PM

It does sound to me like a naming conflict, as if when you use the unqualified name, it's resorting to DNS naming instead of Windows naming, or vice versa. IOW, using the unqualified name makes the search for resolution different, changing it to either DNS or Windows. It’s hard to be more specific because either is possible depending upon your configuration.

Is it possible you installed something recently, say anti-virus/anti-malware, something that may have changed your network configuration? Perhaps your hosts file ( %SystemRoot%\system32\drivers\etc\hosts )? These products often add host entries, and that might be affecting you negatively. Just a guess.
m
0
l

Best solution

July 23, 2012 4:27:20 PM

Try running clearing out all the network cache items on your computer

arp -d *
nbtstat -R
ipconfig /flushdns
ipconfig /registerdns

Reboot, see if this fixed it.
Share
Related resources
July 23, 2012 6:44:13 PM

Thanks eibgrad and hang-the-9. My hosts file is a generic sample file no real entries.
It was the flushing of the DNS resolver cache, (ipconfig /flushdns), that took care of the issue. All's right with the world, (at leat mine), for now.
Thanks again for the help - much appreciated.
m
0
l
July 24, 2012 3:21:25 PM

Best answer selected by SamuraiDave.
m
0
l
May 20, 2014 12:32:04 AM

In the Local Group Policy Editor,

go to- Run --> gpedit.msc --> Local Computer Policy-> Computer Configuration-> Windows Settings-> Security Settings-> Local Policies-> Security Options

Find the policy:

Microsoft network client: Digitally sign communications (always)

If this is enabled, change it to Disabled. Be sure and restart your machine for the change to take effect! Pressing the "Apply".

After restart the system may be any pop will come just click on yes button
m
0
l
!