Sign in with
Sign up | Sign in
Your question

Simple crossover network. Not so simple problems.

Last response: in Networking
Share
July 24, 2012 10:53:22 AM

Good afternoon,

I'm currently trying to connect two computers together using a crossover cable. No router, modem or switch. But the damn thing just won't work.

The set up:

Desktop (windows 7) and laptop (also, windows 7) are connected via the cable in their ethernet ports.

Desktop IP = 192.168.2.1
Desktop subnet mask = 255.255.255.0
Desktop gateway = 192.168.2.2
Desktop DNS = 192.168.2.2

Laptop IP = 192.168.2.2
Laptop subnet mask = 255.255.255.0
Laptop gateway = 192.168.2.1
Laptop DNS = 192.168.2.1
(the gateway and DNS being the opposite computers IP is the only way I could get the networks to identify and become home networks)

The problem:

Both computers say they are connected to a network (although different network names, but maybe that's just choices set on the computer) when the cable is plugged in, but neither can see each other, ping each other or recognise if I make a homegroup on either computer. Both computers networks disappear if I remove the cable. I cannot find any shared folders at all. I cannot type in \\NEMO or \\MOSCHETTI (the computers names) as it will not find it.

Network diagnostics on my desktop come up with "your broadband modem is experiencing connectivity issues" and "the connection between your access point, router, or cable modem and the internet is broken" but I do not have a modem at all. I think that might be it analysing the wireless instead of the ethernet, which is not available for use anyway.

While trying some different things on the computer \\NEMO has shown up in the network section of the other computer. Only to get my hopes up, be clicked on, and then come up with an error about not being found.

I have tried a few different solutions I've found on the internet, but I'm willing to reiterate any of them if you have recommendations.

Thanks for any and all help.
a b D Laptop
July 24, 2012 12:30:26 PM

Might be a firewall issue, try turning off the firewalls on each PC.

Btw, if these are modern PCs, you don't need a crossover cable, a standard cable will work just fine (in fact, I would try a standard cable if the problems persist).

Also, I'm not a fan of cross-referencing the gateways and DNS servers. There's no reason to specify these if they are not in fact offering these services. It might lead to unexpected behaviors. A simple IP + subnet mask should be all that's necessary (regardless of your issue w/ the network name and type).
m
0
l
July 25, 2012 4:51:26 AM

Both computers only use AVG (which doesn't have a firewall, and windows built in firewall. For these tests I have turned them off.

I originally used a normal cable (and not a crossover) but it was no different. I only included the information of using a crossover cable so it might exclude some theories.

I have cropped the gateways and dns servers entirely from the ip4. Now they both only specify ip address and subnet mask. Unfortunately, that makes the networks show up as unidentified and therefore private only. I do have the private network part of the firewall turned off as well and the advanced sharing settings do have all of the network discovery and the likes allowed.
m
0
l
Related resources
a b D Laptop
July 25, 2012 1:11:14 PM

IIRC, you should be able to change the name and type of network for this connection by using the Network Sharing Center. You just click on the name or icon, respectively. Not that it should really matter. A private/home/work network is considered trusted, whereas a public network is not. So if anything, private should be less of a problem than public. But I'm not sure any of this is related to the immediate problem.

Assuming it’s not a firewall issue, the fact you can’t ping one machine from the other means you don’t have basic connectivity established (i.e., your TCP/IP config is wrong). But it’s a pretty simple configuration, so hard to mess up (and yours seems right). It usually works immediately.

As with any MS p2p network, you need to take care of all the other details; each as to be part of the same named homegroup/workgroup, you need the same username/password on each computer, etc. I assume you have.

Just out of curiosity, try using explicit IP references rather than names:

\\192.168.2.1\<share-name>

If that doesn’t work, one last idea. Try setting each PC’s TCP/IP configuration to DHCP. I know that may sound counter-intuitive, but by using DHCP when a DHCP server is not available, it will force the computers to SELF-CONFIGURE themselves using the 169.254.x.x network. Each will randomly generate a unique IP within that network (and you can determine specifically which one w/ ipconfig). At the very least, assuming there are no firewall issues, they should be able to ping each other.
m
0
l
July 26, 2012 1:29:05 AM

hmm, not sure, but, make sure network names are the same, ie, workgroup, and permissions, permissions, permissions. right click the folder you want to share and play with the sharing tabs and security tabs. ie, i only used the sharing tabs, but it wouldn't work, then i used security tabs, and i was able to connect. i only used the cat 5 cable though.
m
0
l
July 26, 2012 2:29:46 AM

eibgrad said:
IIRC, you should be able to change the name and type of network for this connection by using the Network Sharing Center. You just click on the name or icon, respectively. Not that it should really matter. A private/home/work network is considered trusted, whereas a public network is not. So if anything, private should be less of a problem than public. But I'm not sure any of this is related to the immediate problem.

Assuming it’s not a firewall issue, the fact you can’t ping one machine from the other means you don’t have basic connectivity established (i.e., your TCP/IP config is wrong). But it’s a pretty simple configuration, so hard to mess up (and yours seems right). It usually works immediately.

As with any MS p2p network, you need to take care of all the other details; each as to be part of the same named homegroup/workgroup, you need the same username/password on each computer, etc. I assume you have.

Just out of curiosity, try using explicit IP references rather than names:

\\192.168.2.1\<share-name>

If that doesn’t work, one last idea. Try setting each PC’s TCP/IP configuration to DHCP. I know that may sound counter-intuitive, but by using DHCP when a DHCP server is not available, it will force the computers to SELF-CONFIGURE themselves using the 169.254.x.x network. Each will randomly generate a unique IP within that network (and you can determine specifically which one w/ ipconfig). At the very least, assuming there are no firewall issues, they should be able to ping each other.


Thanks for your help so far eibgrad. Unfortunately I meant to specify that it is PUBLIC not private. And that is an unchangeable by click on it in the network and sharing center.

Both are specified to use the 'WORKGROUP' workgroup. Neither use passwords anymore.

I have attempted to use IP references instead of names. To no avail.

I have removed the static IP addresses as request. The new automatic address come up as following

Desktop IP: 169.254.9.248

Laptop IP: 169.254.94.222

Both subnet: 255.255.0.0
Both gateway: missing
Both DNS servers: fec0:0:0:ffff::1%1 {etc}

Kingfencer: All of that is already set up. thankyou
m
0
l
a b D Laptop
July 26, 2012 2:31:04 AM

And you can not even ping between those 169.254.x.x addresses?
m
0
l
July 27, 2012 4:02:10 AM

Cannot even ping.

I have never had such a strange problem before. If it helps, I have updated my drivers to the latest available.
m
0
l
a b D Laptop
July 27, 2012 4:06:51 AM

From a command line on each PC, clear your network caches, then reboot.

arp -d *
nbtstat -R
ipconfig /flushdns
m
0
l
July 28, 2012 7:21:36 AM

Unfortunately this hasn't changed anything :/ 
m
0
l
a b D Laptop
July 29, 2012 7:00:40 AM

If you only have the two PCs, connected by a wire, and even self-configured w/ DHCP, and you can’t even ping the other, then unless there's a firewall on one PC or the other, it can only be a hardware issue. That's pretty much the bottom of the barrel when it comes to diagnosing this problem (assuming the network cards are known to work outside the context of this particular peer to peer setup).
m
0
l
a b D Laptop
July 29, 2012 8:46:29 AM



I had hoped never to admit to this one in public but the last time I struggled with a similar problem, it turned out that one of the PCs had an onboard NIC and another in a PCI slot and I had cabled to the wrong one.

I say this in case anyone else has been unfortunate enough to have made the same completely understandable and forgiveable mistake. :D 

It is also possible that your laptop is one of those who's BIOS needs adjusting if it has an either/or WLAN/ethernet setup so that both can exist at the same time.


m
0
l
July 29, 2012 10:21:14 PM

I'm beginning to think it's must be some form of hardware issue. Both computers only have one ethernet input. Firewalls are most certainly off. Sharing is set up. IPs are configured.

I might check the laptop's BIOS configuration, but I'm not exactly sure what I'd be looking for. Thanks Saga Lout/eibgrad.
m
0
l
a b D Laptop
July 29, 2012 10:41:24 PM

I had one other idea (a long shot). Try booting a live Linus distro (e.g., Ubuntu) on one or perhaps both PCs. Maybe a change in OS would reveal something. IIRC, Ubuntu doesn't use a firewall by default.

m
0
l
July 30, 2012 1:57:54 AM

I could look into this. I won't be able to try it for a few days, but I appreciate that through all the trouble and getting nowhere you are still trying to help me. It means a lot.
m
0
l
May 21, 2013 10:20:41 AM

I had the same problem by trying to connect a Windows 7 PC with a Windows 8 laptop throught an ethernet crossover network cable (I think on modern PCs there is no difference if you use a crossover or simple network cable because modern NICs get the job done anyway.

Now lets get to the kernel of the problem here: I think the reason 'cause you can't access your computers through the network is because Windows 7 and 8 doesn't enable sharing by default for public networks.

When you connect 2 computers directly through an ethernet cable the connection is recognized as "Not Identified Network" and Windows automaticaly adds the connection to the public profile which is not enabled for sharing or network discovery by default.

There are 2 solutions for this problem:

1.) Enable network discovery and sharing for the public profile:

Go to Control Panel -> Network and Internet -> Network and Sharing Centrer -> Change advanced sharing settings -> Under the public profile enable network discovery and sharing.

2.) Change the default behaviour of adding "Not Identified Networks" to the public profile:

In start menu search or Metro UI type:
secpol.msc ENTER, go to "Network List Manager Policies", double click: "Unidentified Networks" in location type select: Private and in "User permission" set "User can change location" -> Ok


*Maybe you will have to restart your computer for changes to take effect. I think the second solution is more secure because the public profile was meant to be used for public connections like in hotels, airports, libraries etc and if you enable sharing and network discovery for the public profile others may have access to your network shares at some time, but if you only use your computer at home there will be no problem, greetings from Brazil.

*I've forgot to tell that if you have a home version of Windows you won't be able to run secpol.msc, so you will have to edit the Windows Registry:

For Unidentified networks to be added to the private profile by default:

HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows NT\CurrentVersion\NetworkList\Signatures\010103000F0000F0010000000F0000F0C967A3643C3AD745950DA7859209176EF5B87C875FA20DF21951640E807D7C24

Create a dword value with the name of "Category" and change its data to 1

If the key: 010103000F0000F0010000000F0000F0C967A3643C3AD745950DA7859209176EF5B87C875FA20DF21951640E807D7C24 doesn't exist create it.
m
0
l
!