Cant install win 7 on 1st build

Im a first time builder and I finally got my system to power on but I couldnt install windows. When I have to select a drive my hdd doesnt come up. I tried refreshing and it says <<No drivers were found. Click load driver to provide a mass storage drive for installation>>.

Heres my build
G.SKILL Ripjaws Series 8GB (2 x 4GB) 240-Pin DDR3 SDRAM DDR3 1333 (PC3 10666) Desktop Memory Model F3-10666CL9D-8GBRL

GIGABYTE GA-Z68A-D3H-B3 LGA 1155 Intel Z68 HDMI SATA 6Gb/s USB 3.0 ATX Intel Motherboard

Intel Core i5-2400 Sandy Bridge 3.1GHz (3.4GHz Turbo Boost) LGA 1155 95W Quad-Core Desktop Processor Intel HD Graphics 2000 BX80623I52400

CORSAIR Builder Series CX500 V2 500W ATX12V v2.3

ASUS EAH6770/DI/1GD5 Radeon HD 6770 1GB 128-bit GDDR5 PCI Express 2.1 x16 HDCP Ready Video Card

Western Digital Caviar Blue WD5000AAKX 500GB 7200 RPM SATA 6.0Gb/s 3.5" Internal Hard Drive -Bare Drive
31 answers Last reply
More about cant install build
  1. Hello jc_jr;

    Both data and power cables plugged into the hard drive?
    Can you hear/feel the HDD spin up at power on?
  2. Also, did you check the BIOS to see if the HDD was visible there?
  3. may i ask what you mean by "finally got my system to power on" you still have unresolved issues.
  4. I checked Bios and the hdd isnt visible there. The wierd thing is that instead of saying theres none there its just a blank space.

    I meant finally as in i couldnt find the power cable that powers the cpu fan
  5. Your spec is missing optical drive. Also. do you have a valid Windows 7 DVD?

    Based on your description, one of your storage, mostly optical storage, is not connected correctly. Either power or data cable.
  6. jc_jr said:
    I checked Bios and the hdd isnt visible there. The wierd thing is that instead of saying theres none there its just a blank space.

    I meant finally as in i couldnt find the power cable that powers the cpu fan


    did you buy a "refurbished" HD?
  7. IIRC If using the Sata 6Gbs connection you need to install the drivers for it or it will not be found since the controller is not loading so anything connected to it will not be found by the system. (read through the MOBO manual and see if it mentions anything !)
  8. I forget to list my optical drive its just a generic hp 24x. yeah it is a valid windows dvd.
    Does it matter what sata slot i plug my hdd into.
  9. Im not sure i bought a bare drive dos that mean its refurnished?
  10. It could. You should be able to see the HDD in BIOS even before OS install.

    What did the motherboard manual suggest on which SATA port to use?
  11. No - a bare drive is an OEM drive - not packed in a 'retail box'.
    It's a perfectly good option and most builders get them that way.
  12. mobo didnt say to plug hdd anywhere in specific
  13. not seeing HDD in bios is not a good sign, do you have another one laying around you could plug in to check if its the mb or hdd?
  14. mobo also doesnt say anything about installing drivers until after you install o/s
  15. the only other hd i got is an extra one from a laptop
  16. Try using a different SATA port (use one of the 3Gbs instead of the 6Gbs ports) and see if the drive is then found -- If it is it is not finding it on the 6Gbs due to missing the drivers loading -- Doing this will at least let you know if the driver for the 6Gbs ports is the problem !
  17. jc_jr said:
    the only other hd i got is an extra one from a laptop

    is it sata? you should still be able to plug it in if it is
  18. i tried connecting the laptop drive and it read that one in bios. does that mean my original hd is dead. its still something detected in bios but it doesnt give it a name. I forget to mention this but the first time i turned it on i was able to start installing wondows but it stopped and gave me an error message about the drive
  19. Just to make sure...are all the cable connectors are snugged securely?

    Motherboard SATA port - SATA cable connector - cable -SATA cable connector - HDD SATA data connector

    PSU SATA power cable connector - HDD SATA power cable connector
  20. yes to test the laptop drive i unplugged the cables from the original hd and plugged them in the laptop one and it worked fine. i reconnected them to the original one after and it still wasnt detected properly
  21. hey at least you know its not the mobo!
  22. does that mean the drive is dead?
  23. id keep trying with the hdd but its not looking good. id reset bios and stuff and see if i could get the bios to detect it. once you get the bios seeing the drive you can move on to windows installation.
  24. RMA the drive.
    if you have to do a voodoo dance now to get it going, who knows what problems may happen later.
  25. jc_jr said:
    I forget to mention this but the first time i turned it on i was able to start installing wondows but it stopped and gave me an error message about the drive


    Depends on the error message, and how far into the install you were. If you got to the point where you format the drive before the error, it could be the drive faulted in a bad way and broke the boot record and formatting.

    If it is not even recognized by the mobo, the drives ROM memory likely is corrupt. I would take the advice of looniam and do a warranty return.
  26. ok thanks. im just going to rma it
  27. quick question is there any problem with installing win7 on my laptop drive and use that as my boot hd
  28. HOLD IT!
    do you have AHCI enabled for the HD in the bios . .then windows will need those drivers before it can install. but your bios should still recognize it . . .hhhmmmm.
  29. ive tried ide, raid, and ahci and rebooted to see if somehow it would be recognized in bios but still nothing it leaves a blank space as if it can detect it but doesnt recognize it
  30. ok. fortunately WD are usually replaced, RMA'd, w/o a problem. it does suck you have to wait though, sorry.
  31. oh well. thanks to everyone that helped.
Ask a new question

Read More

Configuration Windows 7