Sign in with
Sign up | Sign in
Your question
Solved

Using a wirless router as a hub

Last response: in Wireless Networking
Share
July 7, 2012 5:30:58 AM

Hello,

I am living in the sticks in Thailand and am lacking a good internet service.
Recently 3g was made available, and I just manage to get and hold a reasonable connection (3-5mb/s) by putting the 3g dongle on my roof and running a long usb lead down to my pc.

Running virtual router manager on my pc I can connect my iphone/ipad/other laptop and apple tv to the internet, however the wireless from the laptop is weak and when trying to use Apple's TV mirroring, the signal is too weak.

I have an old ADSL router (TP-Link TL-W8961ND), using the Wifi network from this I am able to produce a smooth picture on the Apple TV, but connecting to this network, I lose my internet connection.

Is there anyway I can bridge the 3g connection from my laptop to the router - either wireless or via ethernet cable to share the internet connection, and create a more stable wireless connection at the same time?

Regards,
Brad

More about : wirless router hub

July 7, 2012 5:02:16 PM

So if I understand it correctly, you're using the wifi of your laptop as a hotspot and then bridging that over to the 3G connection (w/ ICS or some other software?). And now you want to replace that hotspot w/ that of the ADSL modem because it offers a stronger signal.

Disable the DHCP server on the ADSL router. Then patch it to the ethernet port of your laptop. Finally, share the 3G connection w/ the ethernet network rather than the laptop's wireless network. I guess it would make sense to actually disable the laptop's wireless network altogether, so either turn off the radio (most laptops have either a soft or hard button), or disable it in Network Connections (Start-> Search box, type “ncpa.cpl” (no quotes) and hit enter).
m
0
l
July 9, 2012 4:30:11 AM

You are correct in your understanding as to what I am trying to achieve, however I have already tried what you suggested and been unsuccessful.
(I should have mentioned this in my first post - alas I have a 2 week old child and I forget the obvious now!)

I can successfully ping between each computer I connect to the LAN or Wifi, however the other computers/devices are unable to connect to the internet.

Should I be attempting to give IP addresses to each device or set the gateways to connect to the internet?

Regards.
m
0
l
Related resources

Best solution

July 9, 2012 3:00:33 PM

Hmm, seems odd you’d be having problems given you already had this working over your laptop's wifi. So the basic pieces are in place. All you're doing is reconfiguring ICS to use the ethernet connection of the laptop instead of the wireless. Not much to mess up there.

The only possible complication is if you forget to disable the DHCP server on the ADSL router. Because ICS runs its own DHCP server, if you left the ADSL router’s DHCP server running, it's possible your clients would get configured by the ADSL router and not ICS. At that point all the clients could talk to each other, but internet access would be impossible since their respective gateway IPs would point to the ADSL router, which of course isn't connected to the Internet. And frankly, that kind of sounds like your recent description.

So double check everything. There just isn't much else to it.
Share
July 10, 2012 5:26:50 AM

Best answer selected by bradlloyd.
m
0
l
July 10, 2012 5:31:56 AM

Worked through everything again and it is all working fine now,
I think my problem arose through trying to configure the router from the same laptop that was using ICS as ICS specifies a default IP address for the LAN connection, which conflicts with the router's IP addresses.
Turned sharing on, configured the router with a different laptop and hey-presto!!
I imagine you could configure the router first, then turn on ICS, but after turning ICS on you can not use the same PC to access the router's configurations settings.

Somebody may be able to advise which way around to configure the IP addresses to allow everything to mesh that little bit better, however I have achieved my goal so I will stop meddling with it all for now!!

Many thanks eibgrad!!
m
0
l
!