Sign in with
Sign up | Sign in
Your question

How to set up a router when it doesn’t detect the WAN?

Last response: in Networking
Share
August 2, 2012 4:51:57 PM

I gave this old router (DGL-4300) to someone far away and couldn’t get it work over the phone.

Normally, I would just connect it to my cable modem and it detects all the WAN IP’s (IP Address, Subnet Mask, Default Gateway, Primary DNS Server, Secondary DNS Server).

However, she lives in a building and her internet comes from the wall where she attaches her Macbook to it via Ethernet. When she connects the router to the wall, the WAN IP’s remain at 0.0.0.0.

How would we go about getting this to work?

Thanks for any! :) 
August 2, 2012 5:24:25 PM

First thing in any such situation it to do a factory reset on the router! Most are designed to work out of the box (for this very reason). Of course, then you'll want to add in wireless security, an administrative password, etc.

Of course, all of this assumes there is internet access available via that ethernet port on the wall. So this is confirmed? Can she connect here computer to it directly and have it work?

One other possibility (as assuming the above is not an issue). It's *possible* the landlord is using MAC filtering to limit access to known, approved devices, like her MacBook. If so, she'd need to either have the landlord add her router's MAC address, OR, clone her MacBook's MAC address to the router's WAN.
m
0
l
August 2, 2012 6:30:57 PM

Factory reseted more than once after "trying things".
Internet from wall works and has worked forever.

You can change your router's IP address? I thought that was a hardware setting done at manufacturing.





Also, can you explain why this "partially" works?:

I got the Subnet Mask and Router from OSX from here...
https://kb.wisc.edu/helpdesk/page.php?id=6526

I entered the Subnet Mask and Router (with a 2 instead of 1) in the DGL-4300 router settings.

I turned DHCP off. IOW, I turned this router into a switch/access point.

I connected the wall to a LAN port (because I assumed there was already a router "somewhere").

I connected the Macbook to another LAN port.

The internet works in this setup. However, wireless does not get to the internet, either for the Macbook, or an iPod. I know the wireless connection works because both the Macbook and the iPod can access the router page. It's just that the internet only works "wired" from the Macbook. Does this have anything to do with "MAC filtering"?
m
0
l
Related resources
August 2, 2012 6:56:03 PM

Here's another possibility. It may be that the upstream router is using the same network as the DGL-4300. If so, that's an invalid configuration and you need to change the DGL-4300 to something else (e.g., if the upstream router is using 192.168.1.x, perhaps make the DGL-4300 192.168.2.x). Otherwise, if they're the same, routing is ambiguous.

You can check to see if this is the case by comparing the network the computer uses when connected directly and comparing it to the one the DGL-4300 uses by default.

And yes, as I said previously, it could be MAC filtering too, although I think the above is much more likely. It's a common error because the 192.168.1.x network is itself so common, and so both systems have a very good likelihood of using the same one, again, that would be an error in configuration.
m
0
l
August 2, 2012 8:21:47 PM

OSX IP Address (direct to wall):
98.150.244.229
255.255.254.0
98.150.240.1

I take it the first IP indicates it's Road Runner.

So I should tell her to set the router to something like...?
255.255.254.0
98.150.241.1


m
0
l
August 2, 2012 10:32:36 PM

Well that's interesting. That appears to be a legitimate public IP address, not some upstream local router managed by the landlord (which is what I had assumed). So the default 192.168.1.x network of the DGL-4300 should work fine.

As I said before, I would try cloning her MacBook's MAC address to the WAN of the DGL-4300 router. That would get around any MAC filtering that may be going on. We know the MacBook MAC works, so cloning it fools the ISP into believing it's the MacBook again, when in fact it's now the router.
m
0
l
!