Sign in with
Sign up | Sign in
Your question

Outside can't Access My Apache Server

Last response: in Networking
Share
August 6, 2012 1:31:11 PM

I have Time Warner Cable with an Arris TM602G modem - my own Netgear wireless (WGR614V6) router. I'm running Windows XP on my PC with Apache (XXAMP) as a web server. I have HTTP listening on port 80 - I did a "netstat -aon" from DOS command and port 80 is listening on a PID that's httpd.exe. I have my Netgear wireless set up with address reservation for my PC - and port forwarding to that IP for my HTTP. My web server is up and running and I can it it from my Iphone browser (inside my network) using the PC's IP address as URL. I have a DSNExit entery for the dynamic IP address with the software downloaded and running to keep my IP address updated and pointing to the correct URL. I can't access my URL from outside my network - I get a "502 bad gateway" error. I can ping it from outside my network. I have the firewall turned off in Windows and on the Modem.

This use to work fine when I had an old Motorola modem - then Time Warner game me a new Arris modem and things are not working anymore. My new dynamic IP adress for the PC updated on the DNSExit site just fine. This issue has been happening for the past 2 weeks - so the dynaimc IP has had time to update.


Should the dynamic IP adress be the same for my PC and the Arris modem? It is and I'm not sure if that is correct. I know this has to be something with the new Modem settings - just not sure what it could be.

More about : access apache server

August 6, 2012 10:48:49 PM

Many ISPs block common ports unless you are on an expensive business plan.
m
0
l
August 6, 2012 11:00:51 PM

I found the issue - my NetGear wireless router settings had the "Router MAC Address" set to "Use Default Address" and I changed that to "Use Computer MAC Address" and its working again. I'm not sure what the "default MAC address" actually is?
m
0
l
August 6, 2012 11:09:42 PM

And found this in the Netgear manual:

Your service provider only allows one Ethernet MAC address to connect to Internet, and may check for your computer’s MAC address.

In this case, inform your service provider that you have bought a new network device, and ask them to use the wireless router’s MAC address.
OR
Configure your router to spoof your computer’s MAC address. This can be done in the Basic Settings menu. Refer to the online help in the wireless router main menu.
m
0
l
!